Talkback missing from mozilla-win32-installer-sea.exe, talkback.xpi 1 kb instead of 254kb

RESOLVED DUPLICATE of bug 218898

Status

SeaMonkey
Build Config
--
major
RESOLVED DUPLICATE of bug 218898
14 years ago
13 years ago

People

(Reporter: Hermann Schwab, Assigned: Daniel (Leaf) Nunes)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031024
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031025

Talkback.xpi contains only file installer.js, no other files or folders,
i.e. folder bin is missing.

I´m mostly installing from the full installer, and sometimes talkback isn´t
installed (missing from the components directory), though I specified full
install. Sometimes loading talkback.xpi did help.

Latest builds missing talkback: 2003102504, 2003102104, 2003100404.

comparing a working (254k) and a corrupt (1k) xpi, I found:
The working one consists of a file install.js and a folder named bin, containing
a folder named components, containing 5 files with current date and 4 files
including talkback.exe with older dates.
Seems to be the reason I couldn´t install yesterdays working talkback.xpi
instead of todays corrupted talkback.xpi in todays browser.


Reproducible: Always

Steps to Reproduce:






Seems to be a major feature as 1.6a should be delivered with talkback.
As this bug happens more often the last weeks, I´m not sure if it is known.
(found no entries in General nor Build/Build Config/build-config)
Is this a mozilla.org server issue?  Or a packaging one?

Comment 2

14 years ago
Any relation to bug 218898?
(Reporter)

Comment 3

14 years ago
Seems that this is a dupe of bug 218898, but here is the info, it is version
trunk, that one is version 1.4, but should be fixed too in 1.4.2

http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.4.1/windows-xpi/
also shows a 1 kb XPI, that writes to the install log only:

-------------------------------------------------------------------------------
http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.4.1/windows-xpi/talkback.xpi
 --  10/25/2003 00:39:46
-------------------------------------------------------------------------------

     Quality Feedback Agent (version 6.5.0.2001012623)
     ----------------------

     ** Talkback place holder .xpi for the real thing.

     Install completed successfully  --  10/25/2003 00:39:47


functions in the install.js, the only file contained in talkback.xpi:

// this function verifies disk space in kilobytes
function verifyDiskSpace(dirPath, spaceRequired)
.....

// this function deletes a file if it exists
function deleteThisFile(dirKey, file)
.....

// this function deletes a folder if it exists
function deleteThisFolder(dirKey, folder, recursiveDelete)
{
.....

// OS type detection
// which platform?
function getPlatform()
.....

// main

var err;

err = initInstall("Quality Feedback Agent", "Quality Feedback Agent",
"6.5.0.2001012623"); 
logComment("Talkback place holder .xpi for the real thing.");
cancelInstall(err);

// end main

Comment 4

14 years ago
See leaf's comment in bug 218898... the status of talkback is uncertain for the
time being...

*** This bug has been marked as a duplicate of 218898 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

14 years ago
Just sent reports to talkback.mozilla.org/spiral-bin/Collector.dll, it is
working since some days, if talkback is included in the build.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.