realplayer plugin doesn't work

RESOLVED DUPLICATE of bug 178805

Status

RESOLVED DUPLICATE of bug 178805
16 years ago
7 years ago

People

(Reporter: ceresna, Assigned: blizzard)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031024

realplayer plugin fails to initialize in GtkEmbed 
 
The plugin is probably installed ok, because when I run 
<top>/bin/mozilla then the realplayer works; 
but if I start <top>/lib/mozilla-1.5/TestGtkEmbed the plugin fails 

Reproducible: Always

Steps to Reproduce:
1.compile mozilla1.5+gtkembed with gtk2 
2.run TestGtkEmbed 
3.load url http://www.cnn.com/audio/radio/realplayer.html 
Actual Results:  
For audio/x-pn-realaudio-plugin found plugin /usr/lib/RealPlayer8/rpnp.so 
LoadPlugin: failed to initialize shared library /usr/lib/RealPlayer8/rpnp.so 
[/usr/lib/RealPlayer8/rpnp.so: undefined symbol: __pure_virtual] 
LoadPlugin() /usr/lib/RealPlayer8/rpnp.so returned 0 
For audio/x-pn-realaudio-plugin found plugin /usr/lib/RealPlayer8/rpnp.so 
LoadPlugin: failed to initialize shared library /usr/lib/RealPlayer8/rpnp.so 
[/usr/lib/RealPlayer8/rpnp.so: undefined symbol: __pure_virtual] 
LoadPlugin() /usr/lib/RealPlayer8/rpnp.so returned 0

*** This bug has been marked as a duplicate of 178805 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.