Closed Bug 223999 Opened 17 years ago Closed 14 years ago

{inc} tables maximized at initial page load

Categories

(Core :: Layout: Tables, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: orubel, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

Problem can also be seen at www.proclub.com

Page does not resize on initial page load; tables load to maximum value of
screen instead of resizing to browser size. Upon reloading the page, it then
resizes properly.

Reproducible: Always

Steps to Reproduce:
1.load website layed out in tables in minimized browser
2.notice how page is rendered to maximized size.
3.reload page in minimized browser.
4.notice how page is now rendered properly.

Actual Results:  
Page renders correctly after following those steps.

Expected Results:  
It should have rendered the tables in comparison to the browser size... not in
comparison to MAXIMIZED browser size.

I believe this has something to do with the "width=100%" and "height=100%"
elements of the table tag. On initial load, it assume maximum browser size but
on reloading of the page, it renders it properly.
->Layout, but it seems to work for me if I understand what's being said here.
20031027 PC/Win2000
Assignee: general → other
Component: Browser-General → Layout
QA Contact: general → ian
Confirming bug, 2003-10-25-05 trunk Linux.  100% reproducable with
Shift+Reload, Reload...  After Shift+Reload the computed height of <html> is
2131px, after Reload it is 733px (according to DOM Inspector).
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Summary: tables maximized at initial page load → {inc} tables maximized at initial page load
Attached file Testcase (obsolete) —
-> Tables
Assignee: other → table
Component: Layout → Layout: Tables
Keywords: testcase
The testcase renders the same for me in both:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)
despite reloading, shift-reloading, etc.
Maybe because the image the testcase points to is no longer present?
Attached file Testcase #2
Image URL in old testcase was 404. This testcase shows the bug.
Attachment #134360 - Attachment is obsolete: true
Bug occurs in SeaMonkey 2006120701 (pre reflow branch) on Linux.
Bug does not occur in SeaMonkey 2006120801 (post reflow branch) on Linux.

-> FIXED (by the reflow branch landing)
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.