bestbuy.com - search JS only looks for IE/Netscape

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P2
normal
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Alfonso Espitia, Unassigned)

Tracking

({ecommerce})

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

when you go to bestbuy.com at try to do a search on their website and hit the
ENTER button it will not do the search.  so after hitting the ENTER button, if
you try to hit GO any time after that, it does not work.  Don't know if it's a
moz bug or bestbuy (probably bestbuy), but thought you should look at it as
well.  I will email them as well.

Reproducible: Always

Steps to Reproduce:
1. go to bestbuy.com
2. type in a  search
3. hit ENTER
4. it doesn't submit
5.  try to hit GO instead
6.  nothing happens

Actual Results:  
nothing happens

Expected Results:  
it should have performed the form submission

workaround:
go to the site
type in a search
hit GO the first time, instead of ENTER first

Comment 1

14 years ago
It's probably due to this function that fires when you submit a search.

function handleEnterKeyPress(formName)
{
	var userEnteredValue = formName.txtkeywords.value;
    userEnteredValue = trim(userEnteredValue);

    if(navigator.appName == "Microsoft Internet Explorer")
    {
        if(window.event.keyCode == 13)
        {
			if(searchButtonClicked)
			{		
				return false;
			}
			else
			{
				searchButtonClicked=true;
			}

            if(userEnteredValue == "")
            {
                alert("Please specify a string to search");
                formName.txtkeywords.value = "";
                formName.txtkeywords.focus();
				searchButtonClicked=false;
                return false;
            }
            else
            {
                formName.submit();
            }
        }
    }
    if(navigator.appName == "Netscape")
    {
        canSearch=true;
        if(arguments.callee.caller.arguments[0].which == 13)
        {
			if(searchButtonClicked)
			{		
				return false;
			}
			else
			{
				searchButtonClicked=true;
			}

            if (userEnteredValue == "")
            {
                alert("Please specify a string to search");
                formName.txtkeywords.value = "";
                formName.txtkeywords.focus();
				searchButtonClicked=false;
                canSearch = false;
                return false;
            }
        }
    }
}

It's only looking for IE or Netscape.
->TE
Assignee: general → english-us
Status: UNCONFIRMED → NEW
Component: Browser-General → English US
Ever confirmed: true
Keywords: ecommerce, evang500
Priority: -- → P2
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Summary: bestbuy.com search bar does not work after hitting ENTER → bestbuy.com - search JS only looks for IE/Netscape
Version: Trunk → unspecified

Comment 2

14 years ago
*** Bug 220410 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
wfm in recent trunk. -> fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.