No selected option in a select-lis (dropdown) accepted

VERIFIED DUPLICATE of bug 46845

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 46845
14 years ago
12 years ago

People

(Reporter: Guido Hermans, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When adding a <SELECT> with several <OPTION>s, the selected will not be
selected!  Neither on my .php pages, nor on my .htm pages..

Reproducible: Always

Steps to Reproduce:
1. Add the <SELECT>
2. Add several <OPTION>s
3. Select the standard-selected (other than the first, or last)
4. Display the form/page

Actual Results:  
The form didn't produce the desired result

Expected Results:  
Selected the right option!

Comment 1

14 years ago
Guido, without a testcase or an URL this is very hard to reproduce.
QA Contact: bugzilla

Comment 2

14 years ago
Created attachment 139828 [details]
Testcase

I noticed this in Mozilla 1.6. Mozilla keeps the state of the select box when
refreshing the page ("F5"). Is this the expected behaviour?

Comment 3

14 years ago
(In reply to comment #2)
> I noticed this in Mozilla 1.6. Mozilla keeps the state of the select box when
> refreshing the page ("F5"). Is this the expected behaviour?

bug 46845

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.