many <big> cause Browser crash : "Bad length"

RESOLVED DUPLICATE of bug 192397

Status

--
critical
RESOLVED DUPLICATE of bug 192397
15 years ago
14 years ago

People

(Reporter: pohl, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030829
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030829

The page completely crashed mozilla. See attached additional info.
'BadLength (poly request too large or internal Xlib length erro'
(Details: serial 31288 error_code 16 request_code 154 minor_code 20)

Reproducible: Always

Steps to Reproduce:
1.go to the page

Actual Results:  
crash

Expected Results:  
normal page display

The program 'mozilla-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength (poly request too large or internal Xlib length erro'.
  (Details: serial 31288 error_code 16 request_code 154 minor_code 20)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Comment 1

15 years ago
too many <big>, no </p>, but no crash seen, seems to be invalid HTML.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031028



<HTML>
<HEAD>
  <!-- Created with AOLpress/2.0 -->
  <TITLE>Thorwal im Thorwal Standard</TITLE>
</HEAD>
<BODY BGCOLOR="#ffffff" LINK="#0000ff" VLINK="#0080ff" BACKGROUND="otta-kl.gif">
<P ALIGN=Center>
<BIG><BIG><BIG><BIG><BIG><BIG><BIG><BIG><BIG><BIG><U><BIG><BIG><BIG><B>Thorwal</B></BIG></BIG></BIG></U></BIG></BIG></BIG></BIG></BIG></BIG></BIG></BIG></BIG></BIG><A
    HREF="http://www.vinsalt.de/topsites/lsp/lspro.cgi?click=971368906"><IMG
   
SRC="http://www.vinsalt.de/topsites/lsp/lspro.cgi?display=971368906&amp;logo=default"
    HEIGHT="35" WIDTH="60" BORDER="0" ALIGN="Right"></A>
<P>
(Reporter)

Comment 2

15 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031024 Debian/1.5-2
...crashes as well.

The HTML code is valid, though. </P> is not explicitly required and the nesting
depth of <BIG> should crash the browser!

The only thing you have ruled out is that the bug is not Windoze-related.

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 192397 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Re comment 2:
you should read in Bug 206235  	limit allowed number of nested <big>s
about problems with nesting of <big>s.
Summary: Browser crash : "Bad length" → many <big> cause Browser crash : "Bad length"
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.