Mozilla cant render images with .Jpg extension

VERIFIED DUPLICATE of bug 223055

Status

MailNews Core
Attachments
VERIFIED DUPLICATE of bug 223055
15 years ago
10 years ago

People

(Reporter: Marc Chamberlin, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

I suspect the capital J in the Jpg extension is confusing Mozilla. Try
normalizing to all lower case, the extensionon, before looking up the helper
application to handle the image.

Reproducible: Always

Steps to Reproduce:
1.Post a message with an image attachment to a newsgroup with a .Jpg extension
2.Open the message with Mozilla.
3.

Actual Results:  
Mozilla fails to find a helper application (though it knows it is a jpeg image type)

Expected Results:  
I expected the image to be rendered and displayed.
biesi, the windows code probably needs to lowercase the ext at
http://lxr.mozilla.org/seamonkey/source/uriloader/exthandler/win/nsOSHelperAppService.cpp#334
(just call ToLowerCase on fileExtToUse after appending aFileExt).... what do you
think?

Alternately, we could handle the lowecasing at the nsExternalHelperAppService
level before calling GetMIMEInfoFromOS.. but the other OSHelperAppServices have
to deal with non-lowercase data coming from the OS too, so they're fully
case-insensitive already.
Created attachment 134498 [details] [diff] [review]
Somewhat like that (needs testing)

Someone with a Windows system needs to test this.
Comment on attachment 134498 [details] [diff] [review]
Somewhat like that (needs testing)

<NeilAway> registry is case insensitive
(I wrote a simple test program which confirmed that)

reporter: could you give the url for an example page?
Attachment #134498 - Flags: review?(cbiesinger) → review-
oh nevermind, news... so your real problem is that you get the helper app
dialog, and the page is not rendered? that may have been fixed by bz's recent
checkin to case-insensitively check extensions in GetTypeFromExtension

bz: note that the reporter was using linux :)

(Reporter)

Comment 5

15 years ago
CB You have surmised the problem correctly. 
Ah, yes.  On linux, that would be a problem... ;)  I don't know what I was
smoking....

*** This bug has been marked as a duplicate of 223055 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified DUP.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.