domain name mismatch warning should take foreground

RESOLVED DUPLICATE of bug 74331

Status

defect
RESOLVED DUPLICATE of bug 74331
16 years ago
10 years ago

People

(Reporter: Oddee, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031023
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031023

I have an SSL-encrypted IMAP server that I connect to.  However, the certificate
is for a different site than the server (but within the same domain @
brown.edu).  This causes the Domain Name Mismatch dialog to come up, but the
dialog does not take the foreground.  This is a problem because when the dialog
appears but is not clicked on, you can switch between the different Moz apps
fine, but none of the networking will work - Browser won't browse, Mail won't
load anything.  And it's a pain to find the dialog.

My (inexperienced) proposed solution: Force the Domain Name Mismatch window to
take the foreground.

Reproducible: Always

Steps to Reproduce:
1.Have encrypted IMAP server with a different certificate than the server you
connect to
2.Connect to it
3.Domain Name Mismatch dialog should come up

Actual Results:  
The stated dialog comes up, but is not always in the foreground.

Expected Results:  
The dialog should be forced to the foreground.

Comment 1

16 years ago
I get this as well (but don't have access to change status to NEW).
Product: MailNews → Core

Comment 2

14 years ago
Things on this front are getting better because most modal dialogs are being
replaced by "in page/in tab" error messages. The domain name mismatch one not
yet as far as I know. Duping to bug 74331.

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.