Bug 224263 (rightsizeddefaults)

Mozilla browser default font size is NOT too big

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
15 years ago
6 years ago

People

(Reporter: mrmazda, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: patch, URL)

Attachments

(11 attachments, 3 obsolete attachments)

(Reporter)

Description

15 years ago
"Web designers" believe that users never change the default font size, so they
write all their pages to *lower* the font size from the default, since they
think the defaults look to big.  This causes problems for users for whom the
default isn't too big." David Baron at
<http://bugzilla.mozilla.org/show_bug.cgi?id=24846#c2>

Our evangelism team works to persude people of the wisdom of these words, but
our own web design team does exactly what the evangelizers preach against. If
our own default font size is not "too big", then our own site should be based
upon the default, instead of making the same assumption other designers do.

Currently, the size in body  is set to 10pt, which only in limited circumstances
translates to our 16px default. More commonly 10pt is 2px-3px or so smaller than
the default. Then, virtually everything besides headings and the main content is
sized to "x-small", which at a 16px default, translates to 10px, which itself is
only 1px below the minimum intelligible size on most systems. In places,
"smaller" is used, and the result in IE6 is sub-9px, right where IE6 users need
to read to see how to download Mozilla.

Before and after screenshots on multiple browers and OSes coming up.
(Reporter)

Comment 1

15 years ago
Created attachment 134544 [details] [diff] [review]
up font sizes to standard; narrow rendering disparities among various systems and browsers
(Reporter)

Comment 2

15 years ago
Created attachment 134545 [details]
screenshot group 1
(Reporter)

Comment 3

15 years ago
Created attachment 134546 [details]
screenshot group 2
(Reporter)

Comment 4

15 years ago
Created attachment 134547 [details]
screenshot group 3
(Reporter)

Comment 5

15 years ago
Created attachment 134548 [details]
screenshot group 4
(Reporter)

Comment 6

15 years ago
Created attachment 134549 [details]
screenshot group 5
(Reporter)

Comment 7

15 years ago
Created attachment 134550 [details]
screenshot group 6
(Reporter)

Comment 8

15 years ago
Created attachment 134551 [details]
HTML to load all 6 screenshots in one viewport

As much as possible on one screen makes the overall picture easier to see. High
resolution and big monitor recommended.
(Reporter)

Updated

15 years ago
Whiteboard: patch
(Reporter)

Comment 9

15 years ago
Created attachment 134598 [details] [diff] [review]
fixes http://website-beta.mozilla.org/css/default.css

The beta web site is better in that pt sizing is gone, but still the undersize
font problem remains, which is in part compounded by some font colors that
leave inadequate contrast.

Current authorship, as the past, specifies verdana as first font-family choice,
which compounds the undersizing problem when verdana is not available, since
verdana is the largest commonly available family at any given size. Verdana was
designed to maximize legibility at small sizes. It's large x-height puts it out
of place at ~normal and larger sizes.

Comment 10

15 years ago
*** Bug 225639 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

15 years ago
Since Wang thinks bug 225639 is a dupe of this, copying over those cc's.

This bug really is about reconciling the browser with the web site, vs. (225639)
about the new web site itself. IOW, (this) a web site doesn't need to change the
font size if the initial browser default is correctly sized, but if it is not
(summary contra: it is too big), it should be changed in our browser products
being released; vs. (225639) the (new) web site is not 100%-based, and should be
made so.

Couching this bug so makes the product and component wrong, but unless/until
there is consensus to keep the two bugs distinguished, leaving as is.
Alias: rightsizeddefaults

Updated

15 years ago
QA Contact: imajes → stolenclover
reassigning endico's bugs to default owner
Assignee: endico → mozilla.webmaster
(Reporter)

Comment 13

14 years ago
Created attachment 165557 [details] [diff] [review]
patch for post FF 1.0 release

When we don't use Verdana, the largest commonly installed font, we have no
justification to suggest smaller than the default on state-of-the-art browsers.


Not everyone has Verdana installed. Imposing small on everyone, regardless
whether Verdana installed, is rude. Mozilla.org should be a flagship of good,
friendly design, and should not create the need to zoom that is so widely
imposed elsewhere.
(Reporter)

Updated

14 years ago
Attachment #134544 - Attachment is obsolete: true
Attachment #134598 - Attachment is obsolete: true
(Reporter)

Comment 14

14 years ago
Created attachment 165630 [details] [diff] [review]
patch - simply sans-serif for headings too

Indirectly, mpt suggested body font should be the same as heading font.
Attachment #165557 - Attachment is obsolete: true
Steve Garrity is in transit at the moment but I mentioned this to him earlier
this evening and we agreed INVALID. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 16

14 years ago
Please explain what makes this invalid.
Ben not to be disrespectful of you, but can you please explain why this is
INVALID, when in-fact a user sets font-settings to their liking for a reason,
and munging with those just because the page designer, or a few people who work
on the page feel "the default is too big", yea so what...

the default is too big FOR YOU, set your UA font size lower, and design a
correct size, a user should not need a user-stylesheet full of @-moz-document
rules just to make the pages he or she visits "useable", the _user_ cannot be
expected to know how to do that, the _user_ can be expected to change their font
size, if the "default font" is too small, or too big...not the web-author
themselves.

Please promote the accessability factor of using standards, by actually using
them, validating is not enough, just being valid does not equate useability nor
standards, remember that.
[/rant]

Comment 18

14 years ago
From http://www.mozilla.org/projects/website/ - 
 "Strive to find font settings that are readable on the majority of systems for a
  cross section of users with the default settings."
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 19

14 years ago
Created attachment 166422 [details]
home page today - body {font-size: small} on gtk2-xft screenshot

No verdana on the system. 16px default.
(Reporter)

Comment 20

14 years ago
Created attachment 166423 [details]
as should be today - body {font-size: medium} on gtk2-xft screenshot

No verdana on the system. 16px default.

site css was overridden via simple userContent.css @-moz-document rule
We understand the logic behind this patch. However, we have decided that making
the site look as professional and readable as possible on Windows systems is a
significant enough goal that it trumps leaving the default font size.

Felix - given that we understand and appreciate your argument, but are still
deciding to reject this patch, please don't both further arguing for it here on
this bug. You have made your point well.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 22

14 years ago
Created attachment 166478 [details]
home page today - body {font-size: small} IE6 WinXP screenshot

No verdana on the system. Browser font setting as shown. 96 DPI. Paragraph text
here is physically smaller than on Linux.

Exactly who is "we"? According to http://www.mozilla.org/projects/website/,
exactly one web site driver has commented in this bug against fixing it, and he
didn't actually address any issues in marking wontfix. An unlisted site project
participant commenter addressed virtually no points raised in previous
comments, yet he marked it wontfix, after it was reopened by a listed site
project driver.

Is the rationale to wontfix meant to be kept secret from the general public?
Should a tiny few be allowed to degrade the contributions of thousands in an
open source project this way? Don't these people deserve to have this on the
record?

If "making the site look as professional and readable as possible on Windows
systems" is the goal, then those responsible have failed. Truly professional
web sites don't make paragraph text the same size as the tiny little browser
menu text. To quote myself: 

"There is good reason for toolbar fonts to be smaller than page text. Users
soon become familiar with menu items and what they represent, becoming routine
targets to click to achieve quick action. Web page content isn't at all like
that, mostly being unfamiliar and more voluminous, generally requiring some
attention and focus to assimilate. Larger than menu page text facilitates this,
while smaller menu fonts save some space to allot to the content."
<http://members.ij.net/mrmazda/auth/defaultsize.html#note1>

Not honoring user defaults for normal page text is rude, and rude is not
professional. Mozilla.org should be a stellar example of best practices, not
just another example of rude author behavior rampant on the internet.
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.