Closed Bug 224283 Opened 16 years ago Closed 16 years ago

table element inheritances do not work

Categories

(Core :: CSS Parsing and Computation, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 4510

People

(Reporter: rln, Assigned: dbaron)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

If I specify for example background-color: red in a COLGROUP statement, it is not 
inherited to the TD statement. Specifying the style in the TD, in TR or in TABLE 
works.

Reproducible: Always

Steps to Reproduce:
Try the following example:

<TABLE>
  <COLGROUP> 
   <COL STYLE="background-color: red;">
   <COL STYLE="background-color: green;">
  </COLGROUP>
  <TR>
   <TD STYLE="background-color: green;"> A </TD>
   <TD STYLE="background-color: red;"> B   </TD>
  </TR>
  <TR>
   <TD> C </TD>
   <TD> D </TD>
  </TR>
</TABLE>


Actual Results:  
A and B change background colour, C and D don't.

Expected Results:  
A and D should change to green, B and C to red.

I get the same results using COLGROUP, example:

<TABLE>                                
  <COLGROUP STYLE="background-color: red;"></COLGROUP>
  <COLGROUP STYLE="background-color: green;"></COLGROUP>
  <TR>
   <TD STYLE="background-color: green;"> A </TD>
   <TD STYLE="background-color: red;"> B   </TD>
  </TR>
  <TR>
   <TD> C </TD>
   <TD> D </TD>
  </TR>
</TABLE>

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.