Closed Bug 224354 Opened 21 years ago Closed 21 years ago

the 10/31 build unexpectedly quits before even completely starting

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: dipsomaniac, Assigned: mikepinkerton)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031030 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20031030 Camino/0.7+

When starting, almost immediately after the title screen appears Camino
unexpectedly quits.  I am using 10.3.  Previous builds did not have this problem

Reproducible: Always

Steps to Reproduce:
1. just start Camino
2.
3.

Actual Results:  
it crashed

Expected Results:  
it should have started normally and displayed a window open to my home page
from Console:

2003-10-31 23:12:08.733 Camino[503] Embedding init failed.

2003-10-31 23:12:08.734 Camino[503] Failed to initialize mozilla prefs


2003-10-31 23:12:23.354 CrashSubmitter[509] Crash report submitted!

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

libpng warning: Incomplete compressed datastream in iCCP chunk

libpng warning: Profile size field missing from iCCP chunk

Info: sending header...

Info: AMeterAppProxy::SendEvent failed

Info: sending users...

Info: AMeterAppProxy::SendEvent failed

/Applications/Camino.app/Contents/MacOS/Camino: can't map file:
/Applications/Camino.app/Contents/MacOS/plugins/MRJPlugin.plugin ((os/kern)
invalid argument)

2003-10-31 23:15:57.591 Camino[527] NSImageCell's object value must be an NSImage.

2003-10-31 23:18:45.000 Camino[527] NSImageCell's object value must be an NSImage.

2003-10-31 23:24:37.505 Camino[527] NSImageCell's object value must be an NSImage.

I'm getting a crash too:

2003-10-31 20:36:53.793 Camino[1010] An uncaught exception was raised
2003-10-31 20:36:53.793 Camino[1010] *** -[NSCFString setString:]: Range or
index out of bounds
2003-10-31 20:36:53.793 Camino[1010] *** Uncaught exception: <NSRangeException>
*** -[NSCFString setString:]: Range or index out of bounds
2003-10-31 21:13:07.753 Camino[1017] Window will close notification.
2003-10-31 21:13:07.807 Camino[1017] Browser controller died.
2003-10-31 21:22:37.328 Camino[1017] Window will close notification.
2003-10-31 21:22:37.481 Camino[1017] Browser controller died.
2003-10-31 21:22:46.110 Camino[1038] Embedding init failed.
2003-10-31 21:22:46.110 Camino[1038] Failed to initialize mozilla prefs
2003-10-31 21:22:50.672 Camino[1043] Embedding init failed.
2003-10-31 21:22:50.673 Camino[1043] Failed to initialize mozilla prefs
2003-10-31 21:22:59.538 Camino[1046] Embedding init failed.
2003-10-31 21:22:59.538 Camino[1046] Failed to initialize mozilla prefs
marking new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This might be fixed by bryner's checking of
http://bugzilla.mozilla.org/show_bug.cgi?id=181936

upgrading to blocker. It seems that no-one on 10.2 can run the nightlies built
on panther.
Severity: critical → blocker
oops, wrong bug. back to critical
Severity: blocker → critical
*** Bug 224432 has been marked as a duplicate of this bug. ***
d

*** This bug has been marked as a duplicate of 224161 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
oops
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
i can't repro this with today's nightly on panther. does it still happen for you?
Build ID: 2003110308 works okay. Thanks.
closing based on WFM of last comment
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.