If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New news message with same subject gets appended to existing thread

RESOLVED DUPLICATE of bug 164115

Status

MailNews Core
Backend
--
major
RESOLVED DUPLICATE of bug 164115
14 years ago
9 years ago

People

(Reporter: bohms, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030903 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030903 Firebird/0.6.1+

I'm not sure if this is a Back End or the XUL tree view generation problem, so I
settled on the worst case (Back End).


Reproducible: Always

Steps to Reproduce:
1. Compose a new news message with the same subject line as an existing item


Actual Results:  
The message gets appended to the already existing thread

Expected Results:  
A new top-level subject would be created
(Reporter)

Comment 1

14 years ago
If this helps, it it case sensitive.
This might be a news server problem, the same bug occurs Outlook Express.

Comment 2

14 years ago
If it's the same as in 2003112203 (Mac OS X), and indeed the same as most
newsreaders AIUI, then it merely _displays_ the posts in one thread.  It is not
_posted_ to the same thread, as you can confirm by looking at the source and
noticing that there is no References header.

Is this the behaviour you're experiencing?  If so, you are hereby referred to
bug 164115.  Dupe?

Comment 3

14 years ago
One more hint: This also happens in TB0.4 for mails. E.g. messages with
 - no subject
 - "Re:" as subject
end up in the same thread regardless what the header line "In-Reply-To:" says. 

Updated

14 years ago
Blocks: 236849

Comment 4

13 years ago
No response from reporter => dupe

*** This bug has been marked as a duplicate of 164115 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.