Turn stylesheet references, and JS src's into hyperlinks

RESOLVED DUPLICATE of bug 17612

Status

Core Graveyard
View Source
RESOLVED DUPLICATE of bug 17612
14 years ago
7 years ago

People

(Reporter: raccettura, Assigned: Doron Rosenberg (IBM))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
When debugging a webpage, you often view source.  Often you want to view the
source of a stylesheet, or JavaScript.

I propose having the stylesheet and JS src= attributes turned into links (done
so that you can't tell until the mouse is over them).  So that you can easily
view the source without copy/paste.

For example, things like:

<link rel="stylesheet" type="text/css"
href="http://robert.accettura.com/styles-site.css">

	<script type="text/javascript"
src="http://robert.accettura.com/html/nicetitle.js"></script>


A real enhancement, would be to allow all links to work in source, essentially
letting you navigate the site's source code just like the browser can.  That may
be a bit to far though.

The advantage would be allowing a website deveoper to easily view entire sites
source without copy pasting the most problematic areas (stylesheets and JS). 
Saving them time.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 17612 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
Pardon.  Didn't see that.
Product: Browser → Seamonkey

Updated

7 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.