Border-collapse will not be rendered correctly. The caption of the table and two adjacent tables are overlapping wiht the border of the table.

RESOLVED DUPLICATE of bug 155955

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 155955
14 years ago
14 years ago

People

(Reporter: elasslob, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Here is an example:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
        "http://www.w3.org/TR/1999/REC-html401-19991224/strict.dtd">
<html>
	<head>
		<meta http-equiv="content-type" content="text/html; charset=iso-8859-1">
		<title>Border-Collapse Error</title>
		<style type="text/css">
		<!--
		body 	{ background: #FF6347; margin-left:10px; margin-right:0px;
margin-top:10px; margin-bottom:0px }
		td		{ border: 10px #8FBC8F solid; padding:20px; }
		-->
		</style>
	</head>
	<body>
		<table style="border-collapse: separate; border:10px solid blue; float:left;">
			<caption><br>border-collapse: separate</caption>
			<colgroup>
				<col style="width: 100px;">
				<col style="width: 100px;">
			</colgroup> 
			<tr>
				<td>A</td>
				<td>B</td>
			</tt>
			<tr>
				<td>C</td>
				<td>D</td>
			</tt>
		</table>
		<table style="border-collapse: separate; border:20px solid blue;">
			<caption><br>border-collapse: separate</caption>
			<colgroup>
				<col style="width: 100px;">
				<col style="width: 100px;">
			</colgroup> 
			<tr>
				<td>A</td>
				<td>B</td>
			</tt>
			<tr>
				<td>C</td>
				<td>D</td>
			</tt>
		</table>
		<table style="border-collapse: collapse; border:10px solid blue; float:left;
clear:left;">
			<caption><br>border-collapse: collapse</caption>
			<colgroup>
				<col style="width: 100px;">
				<col style="width: 100px;">
			</colgroup> 
			<tr> 
			    <td>A</td>
			    <td>B</td>
			</tr>
			<tr> 
			    <td>C</td>
			    <td>D</td>
			</tr>
		</table>
		<table style="border-collapse: collapse; border:20px solid blue">
			<caption><br>border-collapse: collapse</caption>
			<colgroup>
				<col style="width: 100px;">
				<col style="width: 100px;">
			</colgroup> 
			<tr> 
			    <td>A</td>
			    <td>B</td>
			</tr>
			<tr> 
			    <td>C</td>
			    <td>D</td>
			</tr>
		</table>
	</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Extract the HTML code and display it with the Mozilla browser.
2. 
3.

Actual Results:  
See example.

Expected Results:  
See example.
Created attachment 134668 [details]
reporter's testcase
I think this behavior is correct according to CSS2, but I wouldn't mind it being
changed either.  See
http://www.w3.org/TR/2003/WD-CSS21-20030915/tables.html#collapsing-borders ,
especially:  "Note only half of the two exterior borders are counted in the
table width; the other half of these two borders lies in the margin area."

Comment 3

14 years ago
IMO, this is clearly a bug.  Normal flow boxes should not overlap just because
you specify a border on them.  (If this is what the CSS 2.1 draft says, then it
needs to be changed.)

*** This bug has been marked as a duplicate of 155955 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.