Closed Bug 224792 Opened 18 years ago Closed 18 years ago

Download manager gets overloaded and spends too much CPU time (downloads.rdf)

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 159107

People

(Reporter: demosten, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Download manager gets overloaded and spends too much CPU time after a long use. 
This might not be I bug but a bad XML parser but I better report it.
I did some research of the problem and it seams that renaming downloads.rdf in
my profile directory fixes the problem. downloads.rdf is 3.92Mb big and spends
more than 5 secs full CPU time to start a new download. Meanwhile mozilla is not
responding. About 10 seconds is taken to remove a single entry from download
list on my Athlon 1.7Ghz. I've also found that there is a xml tag with many
children in the middle of the file:
  <RDF:Seq about="NC:DownloadsRoot">
    <RDF:li resource="E:\Download\books\ArtOfOS.html"/>
    ..... (more 7000+ children) .....
  </RDF:Seq>

Reproducible: Always

Steps to Reproduce:
1.Make your donwload list BIG > 4Mb (about 80000 lines)
2.Try more downloads
3.Try to remove downloads

Actual Results:  
100% CPU usage and at least 5 second mozilla not responding on 1.7Ghz Athlon

Expected Results:  
Work much faster :)
I noticed this to.  Mine is 2.6MB's in size.  What appears to be quite a few
downloads.

I'm using a 1.8GHz P4M laptop with 1GB RAM.  Freezes for a few seconds with 90%
CPU on Mozilla

What's interesting, is it takes about a +5MB in RAM to delete an item.  Some is
released, but each time it grows.  I delete several items, and I find I grew an
extra 10MB's of RAM usage.

I think the solution would be to have Download Manager eventually delete items
after say 500 by default.  

I'll mark as new, since I see no obvious dup.  I'm not sure if this is a bug
though.  What can you expect with a 3.92MB's download RDF data?
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 159107 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Summary: Download manager gets overloaded and spends too much CPU time → Download manager gets overloaded and spends too much CPU time (downloads.rdf)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.