Menu displayed but unreachable by mouse

VERIFIED DUPLICATE of bug 102695

Status

()

defect
VERIFIED DUPLICATE of bug 102695
16 years ago
11 months ago

People

(Reporter: jc.broudin, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

When mouse goes over the "Group and activities" menu on the main page, a menu is
displayed, but separated from the menu bar by a blank. The consequence is that,
when displacing the mouse over, as it leaves the menu bar but has not reached
the menu yet, then Mozilla interprets it as a new will from user and stops
displaying the menu, therefore menu is unreachable.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.thalesgroup.com
2.Displace mouse over the bar menu "Group and activities": the related menu is
displayed
3.Try then to select a choice in the menu by displacing the mouse from bar menu
towards the menu being displayed.

Actual Results:  
The menu just displayed disappears before being reached by the mouse cursor.

Expected Results:  
The menu should still be displayed and the user should be able to select a
choice in the menu.

This does not happen using Internet Explorer 6.0
Smells like to be a duplicate of bug 191016... Or related to it.
The dropdown menus seem to have a margin around them. If you move your mouse
pointer *really fast* on the menu, sometimes it stays there. Finding a way to
eliminate those margins may help as a workaround to this problem. I suspect that
the margins aren't really "part" of their corresponding element, so maybe this
is no valid bug. Changing HW/OS to "All" anyway, since this happens on Linux too.
OS: Windows XP → All
Hardware: PC → All
Oops, I was wrong about the margin. Seems to be an absolute-positioned DIV
instead. I wonder how they calculate the position. Their code is quite big and
complex and thus not very easy to debug... ;-)

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.