Last Comment Bug 224886 - Support http_proxy
: Support http_proxy
Status: NEW
:
Product: Webtools Graveyard
Classification: Graveyard
Component: Tinderbox3 (show other bugs)
: Trunk
: x86 Linux
: -- normal with 2 votes (vote)
: ---
Assigned To: John Keiser (jkeiser)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 06:09 PST by Christian Reis
Modified: 2014-06-16 14:01 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Christian Reis 2003-11-06 06:09:01 PST
Tinderclient currently has a problem when behing an http_proxy. 
Turning this on is trivial with LWP; basically calling

    $this->{UA}->env_proxy()

in tinderclient.pl's initialization. Sound correct?
Comment 1 John Keiser (jkeiser) 2003-11-07 09:03:00 PST
Sounds like it's probably right.  I suggest making this a config variable, so
that there are no changes to the admin interface.  (By this I mean the machine
config, that set of name/value textboxes.)  Basically the only things to change
would be the default setup (so that people know this variable exists) and the
client (to grab the variable from the server and call that method).  Maybe
http_proxy=blah?
Comment 2 Christian Reis 2003-12-15 11:24:04 PST
You can just use the env_proxy() call with no parameters to grab this from the
standard environment variable http_proxy. Something like:

+kernel_tinderclient_patched/tinderclient.pl
--- kernel_tinderclient/tinderclient.pl 2003-11-06 21:55:26.000000000 -0800
+++ kernel_tinderclient_patched/tinderclient.pl 2003-12-11 10:28:06.000000000 -0800
@@ -206,6 +206,7 @@
   # The user agent object
   $this->{UA} = new LWP::UserAgent;
   $this->{UA}->agent("TinderboxClient/" . $TinderClient::PROTOCOL_VERSION);
+  $this->{UA}->env_proxy();
   # the tinderclient.log out
   $this->{LOG_OUT} = undef;
   # the tinderclient.log in
Comment 3 Ricardo Almeida 2010-03-19 03:00:39 PDT
Well, it's 2010 and it still doesn't work :(

http_proxy suport would be greatly appreciated.
Comment 4 Stanislav GE 2010-05-11 06:00:14 PDT
I'm totally agree.
It would be nice if Firefox use http_proxy, ftp_proxy and https_proxy settings while "Use system proxy settings" are enabled.
Comment 5 Kyle Guinn 2012-09-15 23:52:08 PDT
(In reply to Stanislav GE from comment #4)
> I'm totally agree.
> It would be nice if Firefox use http_proxy, ftp_proxy and https_proxy
> settings while "Use system proxy settings" are enabled.

I think bug 66057 was supposed to fix this, but apparently it didn't.

Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120830 Firefox/15.0 SeaMonkey/2.12

Note You need to log in before you can comment on or make changes to this bug.