if a new message is marked as spam, don't display new mail notification(s)

VERIFIED DUPLICATE of bug 189289

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED DUPLICATE of bug 189289
14 years ago
9 years ago

People

(Reporter: benw, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

i have mozilla's spam filters running pretty nicely now after months of
training. it recognizes 90% of my spam and hasn't had a false positive in months.

i've got it set to move messages marked as junk to a seperate folder, and (in
theory) i'm looking through them every day/week or so to make sure there are
none in there that shouldn't be, and then deleting them. what actually happens
though is that a new message comes in, and i see the new message notification
(which in my case is a system tray icon on windows). so i switch to mozilla mail
only to discover that it was merely spam, and it's sitting in my junk folder
looking unread. i can't handle mail i don't want to read wanting my attneiont by
neing all bold and stuff, so i change to my junk folder, right click on the
message and delete it straight away.

what i want is, if a new message is marked as junk, for it to be silently moved
to the junk folder (possibly also marked as read), and - here's the key bit of
this enhancement - the new mail notification(s) not activated. that includes the
change in product bar[1] icon, any popups and/or sounds, and the system tray
icon. basically, if a spam mail comes in, i don't want to know about it at all
until i choose to go through my junk mail folder.

[1] not sure about the name? the thing i meant is that area in the bottom left
of the status bar where the icons for navigator, mailnews, composer, calendar
etc sit.

Reproducible: Always

Steps to Reproduce:

*** This bug has been marked as a duplicate of 189289 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

9 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.