Replied message should be the immediate descendant of the message, not the top level parents

VERIFIED DUPLICATE of bug 22055

Status

MailNews Core
Backend
P3
normal
VERIFIED DUPLICATE of bug 22055
18 years ago
10 years ago

People

(Reporter: fenella, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux Redhat 6.0 (1999-12-22-08 M13)
Win_nt 4.0 (1999-12-22-08 M13)
Mac (1999-12-22-08 M13)
Summary: Replied message to a decendant message should be the immediate
descendant of the decendant message, not the top level parent message
Steps:
1. Launch Messenger using the -mail option
2. Select a decendant (msg 2) of a message (msg 1) , reply to msg 2..
3. View the replied message (msg 3) that is sorted by thread

Actual result: the replied message (msg 3) is displayed in the thread view as a
child of the first level parent (msg 1).
> msg 1
 > msg 2
 > msg 3

Expected result: the replied message should be displayed in the thread view as a
child of the second level parent:
> msg 1
 > msg 2
  > msg 3

This problem occurs in all 3 platforms.

Updated

18 years ago
Assignee: phil → bienvenu
Target Milestone: M14

Comment 1

18 years ago
Reassign to bienvenu, cc putterman. Seems like a beta stopper, so marking M14.
(Assignee)

Comment 2

18 years ago
this is not a threading bug. The message composition/sending code is not putting
the references header in, so I can't thread by references very well. If you send
these messages with 4.x, 5.0 will thread them just fine. I'll try to figure out
why this is broken, but I don't know anything about the message compose code.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
*** This bug has been marked as a duplicate of 22055 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

18 years ago
Mark it verified/dup.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.