Status

()

Core
Layout: R & A Pos
RESOLVED DUPLICATE of bug 225811
14 years ago
14 years ago

People

(Reporter: Tim De Pauw, Unassigned)

Tracking

({qawanted})

Trunk
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031107 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031107 Firebird/0.7+

The actual content area is initially hidden, but it should appear as soon as the
page has been loaded. This used to work in older versions of Mozilla (around
Firebird 0.6), and suddenly it's stopped.

Reproducible: Always

Steps to Reproduce:




I haven't got the time to trace the JavaScript so I can't give you guys any more
details atm, sorry.

Comment 1

14 years ago
http://symbio.sourceforge.net/beta/img/cows/style.css, line 9:
body {
  overflow: hidden;
}

The body have zero height since its children are positioned
Assignee: general → position
Component: DOM Style → Layout: R & A Pos
OS: Windows XP → All
Hardware: PC → All

Comment 2

14 years ago
David, Boris - there have been a few of these reported lately and I'm getting
confused wether our behaviour is correct or not.

http://www.w3.org/TR/CSS21/visufx.html#propdef-overflow:
"This property specifies whether content of a block-level element is clipped
when it overflows the element's box. It affects the clipping of all of the
element's content except any descendant elements (and their respective content
and descendants) whose containing block is the viewport or an ancestor of the
element. "

So there seems to be an exception for positioned descendants with the viewport
as the CB.  On the other hand, later it says:
"HTML UAs may apply the overflow property from the BODY or HTML elements to the
viewport."

So I guess our behaviour is conformant - but is it what we want?

(Why does the spec say "viewport" here - shouldn't be "initial containing block"?)

I'm confused, enlighten me ;-)
Keywords: qawanted
(Reporter)

Comment 3

14 years ago
So for me to have a quick fix, I would have to...

- ... set <body> overflow to the default; enclose the whole thing in a 100%*100%
<div> with overflow: hidden

- ... set <body> width and height to 100%

- ... ?

I'm confused by the rec too, but I have to say the initial behavior makes more
sense to me.

Anyway, I'd like to find a way to make it work in just about any Firebird
release, especially since I keep promoting the browser to everyone, including
users of Symbio itself.
(Reporter)

Comment 4

14 years ago
Note that the whole thing opens in a popup window. Perhaps I could set <body>'s
width and height to that window's dimensions?
Reporter, if you just want no scrollbars, I suggest overflow:hidden on <html>
instead of <body>.

As for CSS2.1, this is a change from 2.0 as far as I can tell...  Ian, what is
the exact intent of that verbiage?  Some examples would go a long way here.
(Reporter)

Comment 6

14 years ago
Using html { overflow: hidden } instead yielded the same result in the same
build, but added a scrollbar in IE6.
Oh, right.  Because IE doesn't really know <html> exists...

You could also set height on <html> and <body> to 100%.

In any case, the real question here is what's the spec actually saying?

Comment 8

14 years ago
Incorrect, if IE6 would be in (almost) standard compliant mode, it would have
worked. IE6 can style the HTML element, though it can't apply background images
on it :S

I think this behavior would only be correct in XHTML (application/xhtml+xml).
You must style the root element then. The BODY element is in 'XHTML mode' just a
DIV (at least, it should be).
(Reporter)

Comment 9

14 years ago
Boris: That fixed it yeah, thanks.
*** Bug 227642 has been marked as a duplicate of this bug. ***
Depends on: 225811
Tim, is this still an issue?  If you remove the height:100% you added, does the
bug show up?  If so, could you attach a page showing it to this bug report?
(Reporter)

Comment 12

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031223
Firebird/0.7+

It still doesn't show up when I comment out
  html,body {
    height: 100%;
  }

My build is a bit dated, sorry about that. I currently don't have the bandwidth
to download a newer one, but I'll attach the source with the CSS above commented
out, so you can see for yourself.
(Reporter)

Comment 13

14 years ago
Created attachment 138494 [details]
Test case
Yeah, that testcase worksforme in a current trunk build (and your build would be
about when the patch in bug 225811 landed, so may not have the patch).  If you
can test with 1.6 when it comes out and resolve fixed that would be great.
(Reporter)

Comment 15

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040113
Firebird/0.8.0+ (scragz)

Is that enough to mark resolved fixed?
Yep, indeed.  Or rather duplicate.  ;)

*** This bug has been marked as a duplicate of 225811 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.