Closed Bug 225043 Opened 20 years ago Closed 19 years ago

Migration of old chart data should populate "All Open"

Categories

(Bugzilla :: Reporting/Charting, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: altlist, Assigned: gerv)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031021 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031021 Firebird/0.7

When upgrading to 2.17.5, the checksetup.pl does not appear to propagate all the
mining data.  In particular, none of the "All Open" categories were updated. 
But the individual bug_status mining data for each product did get stored into
the series tables.

Reproducible: Always

Steps to Reproduce:
After the upgrade, the new charts shows 0 data points when you try to display a
category with "All Open" status.
Attached file script to fix the tables (obsolete) —
Here's a script that I used to propagate the "All Open" series data.  Seems to
have fixed the problem.
Oh, I get it.

You are saying that the new "All Open" query should have historical data
populated by adding up the relevant columns from the imported data set?

That's a good idea - an enhancement, but a good idea.

Gerv
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 2.18
Yea, I had thought it was a "bug" or an "admin error" since the "All Open"
category was inconsistent with the existing historical data.  

In any case, thanks for earmarking this for 2.18.  It'll prevent confusion when
upgrading.
 
Priority: -- → P1
Summary: checksetup.pl does not appear to completely propagate the series_data table → Migration of old chart data should populate "All Open" etc.
Status: NEW → ASSIGNED
Summary: Migration of old chart data should populate "All Open" etc. → Migration of old chart data should populate "All Open"
Attached patch Patch v.1Splinter Review
This patch populates the new "All Open" series at migration time, based on the
sum of the individual bug counts for all the opened states (NEW + ASSIGNED +
REOPENED + UNCONFIRMED).

Gerv
Attachment #135031 - Attachment is obsolete: true
Comment on attachment 139832 [details] [diff] [review]
Patch v.1

Dave, Myk: is this worth having in time for the upgrade? b.m.o.'s data will
only get migrated once, so if having historical "All Open" data is useful, we
need to check this patch in.

Gerv
Attachment #139832 - Flags: review?(justdave)
Whiteboard: [wanted for 2.17.7]?
Whiteboard: [wanted for 2.17.7]? → [wanted for 2.17.7]? [applied to b.m.o]
Dave: can I get an approval on this, since it was applied to b.m.o.?

Gerv
Flags: approval?
Comment on attachment 139832 [details] [diff] [review]
Patch v.1

it seems to have worked on b.m.o...
Attachment #139832 - Flags: review?(justdave) → review+
Flags: approval? → approval+
Fixed.

Checking in checksetup.pl;
/cvsroot/mozilla/webtools/bugzilla/checksetup.pl,v  <--  checksetup.pl
new revision: 1.259; previous revision: 1.258
done

Gerv
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Whiteboard: [wanted for 2.17.7]? [applied to b.m.o] → [applied to b.m.o]
Whiteboard: [applied to b.m.o]
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.