Modern and Classic are Hosed

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Jerry Baker, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
Built Moz from CVS today because there haven't been any Win32 builds for 11
days. When I start it, the whole app is screwed. If this is Win32 only, there's
not going to be any reports until someone manages to get some Win32 nightlies up.
(Reporter)

Comment 1

14 years ago
Created attachment 135044 [details]
This is how Mozilla looks from CVS right now
Jerry: could you upload your build somewhere so we can test it ? Also, what
build options did you use (not that it should affect the theme..) ?
(Reporter)

Comment 3

14 years ago
Build options
-----
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize=/O2

http://mozilla.bakerweb.biz/mozilla-i686-pc-cygwin.zip

It will only be there a day or two as my bandwidth is limited.
Jerry: I get a 403 Forbidden when trying to download that file. I also get a 404
error when trying to show the error-page.
(Reporter)

Comment 5

14 years ago
My hosting company is now run by morons in India. Someone set a directive to
disallow access to ZIP files server-wide. Have to wait until someone unsets it
before this can go.
(Reporter)

Comment 6

14 years ago
Not that people from India are morons ... just these ones are.

Comment 7

14 years ago
I make my own daily builds on Win32 and this WFM
I've seen this before because of corrupt jar packaging. I was not using cygwin
zip.exe.
(Reporter)

Comment 8

14 years ago
It doesn't have to be from the zip file. The same thing happens running
mozilla.exe right out of the "dist" directory.
(Reporter)

Comment 9

14 years ago
Verified that it's not caused by corrupted JAR files. Replacing the chrome
directory with the chrome directory from my current install (which works fine)
still has the same result.
Try removing "XUL.mfasl" in your profile dir
(Reporter)

Comment 11

14 years ago
Doesn't help. (It's XUL.mfl by the way).
From IRC: several people say their builds (post-28 oct.) are good.
Reporter: -> WFM ?
(Reporter)

Comment 13

14 years ago
I pulled and built again with a fresh tree - same problem. 20031028 trunk has no
problem. Something is definitely hosed here, but what? Where can I get one of
their builds to test?
(Reporter)

Comment 14

14 years ago
Once more, I downloaded the source fresh and built. Same porblem still. I just
changed hosting providers, so this link should now work:
http://mozilla.bakerweb.biz/mozilla-i686-pc-cygwin.zip
Created attachment 135314 [details]
how it looks now

I downloaded your build, and I'm running it now.. This does not seem to be a
theme problem.

Build platform
target
i686-pc-cygwin

Build tools
Compiler	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl	12.00.8804 for 80x86	-TC -nologo -W3 -nologo -Gy
-Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl	12.00.8804 for 80x86	-TP -nologo -W3 -nologo -Gy
-Fd$(PDBFILE)

Configure arguments
--enable-crypto --disable-tests --disable-debug --enable-optimize=/O2
Attachment #135044 - Attachment is obsolete: true
(Reporter)

Comment 16

14 years ago
The other screen capture is just the modern theme. If you want to see some real
nasties, try to use email with this thing. It's unusable. If this is an actual
problem with Mozilla, and not just a weird compiler things, it is a blocker.
Everything should be halted until this is fixed, but since there is no news in
bug 219936, we don't know if/when we will get official Win32 builds again. There
haven't been any for over two weeks, and so there aren't going to be many people
seeing this.
Jerry: since there is noone else on IRC that has this problem, I believe that
something is wrong in your tree or with your buildconfig.. But I cannot say for
sure, ofcourse. I guess we'll just have to wait and see when the mozilla.org
nightly builds start rolling again.
(Reporter)

Comment 18

14 years ago
If there is something wrong with my tree, or build config, it's still a bug with
Mozilla (just not themes). I have pasted my build config here, and the tree is
fresh every time with a make -f client.mk pull_all. I have built Mozilla
binaries in the past (about a month ago) and they did not have this problem.

Comment 19

14 years ago
The screenshots look a lot like bug 101968, which is a profile issue, or a
profile-sharing issue, to be more exact.

Please try with a new profile, and rest assured that Mozilla cvs builds are
usable for me and probably the rest of the world, too...

So Jerry, is this still an issue with a new profile?
(Reporter)

Comment 20

14 years ago
I have never used a version of Netscape after 4.79, so it can't be due to
sharing. I haven't built from CVS in a long time. If I get some time I will try it.

Comment 21

14 years ago
Is this bug still valid ?

Comment 22

13 years ago
->WFM
(most probably dup of bug 101968, but not sure; however, seems to work for
everybody now, cvs builds certainly look better than depicted)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.