Site icons on auth-protected sites causes auth prompt in bookmarks

VERIFIED DUPLICATE of bug 133755

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 133755
15 years ago
12 years ago

People

(Reporter: Target, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

If you bookmark a page that's protected by HTTP AUTH, Firebird attempts to load
the site icon from the bookmarked site when you open your bookmarks. This
results in an unwanted HTTP AUTH prompt.

Reproducible: Always

Steps to Reproduce:
1. Go to a page that has an icon & requires HTTP AUTH, and log in.
2. Bookmark the site and close Firebird.
3. Reopen Firebird and open bookmarks.

Actual Results:  
An HTTP AUTH prompt came up when Firebird attempted to load the site icon for
the bookmarked page.

Expected Results:  
Use the icon from cache, if any, or silently fail HTTP AUTH and display the
default bookmark icon until the user actually chooses to visit the site and
authenticate.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 133755 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
verified.
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.