crash (segfault) in libwidget_gtk2.so with adblock plugin

RESOLVED DUPLICATE of bug 205492

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 205492
15 years ago
15 years ago

People

(Reporter: hules, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031024 Debian/1.5-2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031024 Debian/1.5-2

Firebird 0.6.1 (package from debian/sid), the current nightly-gtk2-build of
FireBird and the mozilla 1.5-2 (package from debian sid) crash very consistently
when I browse the freshmeat.net with Adblock installed and filtering
http://ads.osdn.org/*

Reproducible: Always

Steps to Reproduce:
0.erase ~/.mozilla
1.download and install adblock (latest 0.5d2 build 12, stable release 0.3 also
crashes but the steps to reproduce it are different)
2.filter the following url: http://ads.osdn.org/*
3.close mozilla, restart mozilla
4.go to http://freshmeat.net
5.open menu Tools/Adblock/List all blockable elements
6.mozilla dies

Actual Results:  
mozilla (or firebird) disappears. Running it in gdb indicates that it is a
segmentation fault, in /usr/lib/mozilla/components/libwidget_gtk2.so


gtk2 library is the current debian/sid one: 2.2.4-2. I don't know if it is
related to a specific version of gtk2 or not
(Reporter)

Comment 1

15 years ago
Created attachment 135123 [details]
gdb backtrace
dup

*** This bug has been marked as a duplicate of 205492 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.