firebird redirects to http://www.netbreakthroughs.com/ if localhost does not have any web servers running

VERIFIED DUPLICATE of bug 184433

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 184433
16 years ago
16 years ago

People

(Reporter: bgsmith, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

On both linux and Windows 2000, if enter localhost (localhost:8080 or
localhost:any port) in the the url bar, Firebird will rdirect to
http://www.netbreakthroughs.com/ if apache or other web server is not running on
localhost.

Reproducible: Always

Steps to Reproduce:
1.stop all localhost web servers
2.enter localhost has url
3.hit enter

Actual Results:  
Redirect to http://www.netbreakthroughs.com/

Expected Results:  
Displayed a page not found error.

This is a major problem for me and has stopped me from using Firebird. It has
happened at work and at home. Basically the http://www.netbreakthroughs.com/
site is spamming via a browser redirect.
The site isn't spamming anyone.

When you don't have a server running, Firebird defaults to doing a google search
for "localhost" and returns the first Google result.  The site you are seeing is
the first Google result.

This bug is a dup.

*** This bug has been marked as a duplicate of 184433 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.