Always enable right-click context menu, as one of Web Features options

VERIFIED DUPLICATE of bug 86193

Status

()

Firefox
General
--
enhancement
VERIFIED DUPLICATE of bug 86193
14 years ago
14 years ago

People

(Reporter: Ryuichi KUBUKI, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031110 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031110 Firebird/0.7+

Some sites tries to disable right-click context menu by putting null or popup
event to right-click event in JavaScript to suppress "Back" or "Save Image
As...", for various reasons such as DRM or desired navigation. IMO those attempt
is just as annoying as unsolicited popup, for they can be easily turned down by
disabling JavaScript. If there's option to always enable right-click context
menu as one of Web Features options, it'll be as useful as popup-blocking.

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 86193 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.