Unstable rendering when using :hover pseudoclass and position: fixed

RESOLVED FIXED

Status

()

Core
Layout: R & A Pos
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Edward C. Lang, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Applying the techniques described in Eric Meyer's "Pure CSS Menus" css/edge
page, I wrote a small test page that includes a number of menus containing
submenus in varying directions. When mousing over the toplevel menus (direct
children of the containing <div> elements), the menu is displayed, but the
surrounding area is temporarily garbled. 

For second and deeper level nested menus, there is no apparent rending problem.

I'm not sure of the validity or acceptability of my CSS code, but it works for
Eric and I'd much prefer it if it worked for me, too...

It seems to display correctly in Safari on OS X. (I lose the opacity, but that's
another problem - for some reason on my Debian copy of Firebird 0.6.1, the
opacity property causes that item to disappear. I don't think the opacity
property is causing this effect.) 

Reproducible: Always

Steps to Reproduce:
1. Move mouse over "FOO", in bottom left corner. Observe rendering problem,
particularly at bottom of page.
2. Move mouse up menu to "MORE". Once again, observe rendering problem
3. Move mouse across and up to "GAR". Observe lack of rendering problem.

Actual Results:  
Text jumps around the page - especially down the bottom. 

Expected Results:  
Displayed the menus without mistakenly rendering the rest of the page. Does the
engine actually need to rerender the other bits?

Comment 1

15 years ago
I see this on LInux 2003112309.  I created a minimal testcase and narrowed it
down to #gutter-bottom{position:fixed}.
Bug 207915 is simular to this problem.
Summary: Unstable rendering when using :hover pseudoclass → Unstable rendering when using :hover pseudoclass

Comment 2

15 years ago
Created attachment 136241 [details]
testcase

Use View-> Use Style to change between position:fixed and position:absolute.

Comment 3

14 years ago
Jesiah, what's supposed to be happening in the testcase and what is happening
for you?

Comment 4

14 years ago
When you hover over the fixed position you will see parts of #content slightly
vibrate.  You will have to move your mouse back and forth to really see it.
I see this on W2K 2004092306, but seems to be less noticeable.

Comment 5

14 years ago
Sounds like bug 200479, but it's not (that testcase works for me). Confirming on
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040904
Firefox/0.9.1+ and moving to Layout: R & A Pos.
Assignee: roc → nobody
Status: UNCONFIRMED → NEW
Component: Layout: View Rendering → Layout: R & A Pos
Ever confirmed: true
Keywords: testcase
QA Contact: ian → core.layout.r-and-a-pos
Summary: Unstable rendering when using :hover pseudoclass → Unstable rendering when using :hover pseudoclass and position: fixed
Bug 236080 is possibly related (or even the same), because it is about strange
behaviour of absolutely positioned children of :hover elements.
I think this is WFM in my debug build that has the "frame display lists" patch
in it (bug 317375).
Depends on: 317375
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012614

WFM
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.