PAC: invalid url silently ignored

VERIFIED DUPLICATE of bug 90308

Status

()

--
minor
VERIFIED DUPLICATE of bug 90308
15 years ago
15 years ago

People

(Reporter: jfriedl, Assigned: darin.moz)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7

On the preferences page for proxy settings, there is an option allowing
an "automatic proxy configuration url". This is sweet -- I can use the same
proxy.pac I've used for years. However, the first few times I entered the
url (a file:/.... url, in my case), I got no response (no error message,
nor a confirmation that it had been loaded). Once I finally got my fat fingers
working, the proper url resulted in the proxy.pac going into effect (again,
silently).  It'd be nice if an error were reported if the url is invalid or
404s, and a confirmation reported when successfully loaded.


Reproducible: Always

Steps to Reproduce:
1. Preferences > General
2. select "Connection Settings" button.
3. select the last option ("automatic ...")
4. enter an invalid or nonexistant url


Actual Results:  
nothing apparent

Expected Results:  
display a "oops, couldn't load it" dialog

Firebird rocks.

*** This bug has been marked as a duplicate of 90308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Grrr, sorry for the dup. I know I searched for terms like "auto proxy
configuration" and "proxy.pac", and nothing showed up. Maybe search was
wacky?  Sorry.
I used "Pac URL" as search terms :-)

Comment 4

15 years ago
VERIFIED:
Status: RESOLVED → VERIFIED
Summary: invalid proxy configuration url silently ignored → PAC: invalid url silently ignored
You need to log in before you can comment on or make changes to this bug.