Rename local folder to something with '/' character makes folder unaccessible

VERIFIED DUPLICATE of bug 89986

Status

SeaMonkey
MailNews: Account Configuration
VERIFIED DUPLICATE of bug 89986
15 years ago
14 years ago

People

(Reporter: VaagOH, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030

Mozilla Mail -> Local Folder -> You have one like 'UvT Internet en DRC'. I 
wanted to rename it to 'UvT Internet / DRC' (With '/' instead of 'en').

Renaming it causes the folder to 'loose' all their mails. Restarting Mozilla 
(that is: close all mozilla related stuff) brings back my original foldername, 
and mail.

Suggestion: disable the '/' character as a valid character for local folders.

Reproducible: Always

Steps to Reproduce:
1. Mozilla Mail
2. Local Folders
3. You have one folder like 'UvT Internet en DRC'. I wanted to rename it 
to 'UvT Internet / DRC' (With '/' instead of 'en')
Actual Results:  
Renaming it causes the folder to 'loose' all their mails. Restarting Mozilla 
(that is: close all mozilla related stuff) brings back my original foldername, 
and mail.

Expected Results:  
Disable the '/' character as a valid character for local folders.

I bet it's because of the Windows' filesystem that there can be no '/' 
character in a foldername. But Mozilla tries to rename it, however the actual 
folder isn't renamed. So, 'catching' illegal characters would prevent this 
from happening.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 89986 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.