"Selected" Option not selected on dynamically generated option list.

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 46845
14 years ago
13 years ago

People

(Reporter: jsnod, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031030

In the "Rider Profile" box of http://www.tumyeto.com/main.php, there is a
dynamically generated Option dropdown.  All is fine on first load of the page,
however, upon a reload, the dropdown does not default to the newly defined
"selected" option, it stays focused on the original page load's "selected" option.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.tumyeto.com/main.php
2. Note that the rider name in the Rider Profile and the dropdown form option
are the same.
3. Click re-load.
4. A different rider is now displayed, but the droptdown form option reads the
name of the rider in #2 above.  View source and you will see the new rider's
name has the proper "selected" but Mozilla doesn't select it.  Keep hitting
reload and the form option will always stay at the original rider's name.

Actual Results:  
First rider's name remains as the selected dropdown option, even though the
source shows it on a different rider's name.

Expected Results:  
The dropdown option should default to the correct "selected" option.

I've tried this on multiple versions back to 1.5b, it's been around a while. 
Can't attach a testcase because the option list needs to be dynamically generated.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.