message header count does not update

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: asa, Assigned: scottputterman)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
problem: the message header counts in mozilla news do not update / refresh.

steps to reproduce: select a news group with new messages.  select an unread
message header to display the message or clcik on the little read/un-read green
diamond to change a read message to un-read status.

actual behavior: the message count in the left pane (mail and news server
pane) does not update.

expected behavior: each time a message header is read or marked unread the
unread message count listed in the server pane should reflect that change /
update

tested on win32 build from 12/22 (and other recent builds) under windows98

additional information: the count should also update when you select a news
group and it downloads new headers.

Updated

19 years ago
QA Contact: lchiang → fenella
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
I have a fix for this.  Will attach patch shortly.  I found this because the
same thing was happening in pop.  There's a member variable in local and news
called mPath that used to be a nsNativeFileSpec*.  Someone brought this to the
base class and changed it to an nsIFileSpec but left it in derived classes. This
caused some functions to fail.  I changed the derived versions to use base class
version and everything worked out.
(Assignee)

Comment 3

19 years ago
cc'ing bienvenu in case he's been given bugs that are related to this.
(Assignee)

Comment 4

19 years ago
Created attachment 3925 [details] [diff] [review]
patch for bug.  This is just news directory.  Local is similar.  For some reason Imap is already #ifdef'd out.
Assignee: sspitzer → putterman
Status: ASSIGNED → NEW
re-assign to putterman, as he has the fix.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
i just checked in the fix
verified for news.  I've not tried pop or imap.
nice work, putterman.
(Reporter)

Comment 8

19 years ago
thank you putterman. this fix is really appreciated.
(Assignee)

Comment 9

19 years ago
*** Bug 22182 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
Linux Redhat 6.0 (2000-01-04-08 M13)
Win_nt 4.0 (2000-01-04-09 M13)
Mac (2000-01-04-09 M13)
Message header count update works well. I try it on POP, IMAP and news on all 3
platforms.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.