Insecure dependency in exec while running with -T switch at /var/www/html/<bugzilla dir>/post_bug.cgi line 303

RESOLVED DUPLICATE of bug 177828

Status

()

--
major
RESOLVED DUPLICATE of bug 177828
15 years ago
6 years ago

People

(Reporter: bspidell, Assigned: myk)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

On submission of bug, get the following error message at top of page:

"Sofware Error: Insecure dependency in exec while running with -T switch at
/var/www/html/<bugzilla dir>/post_bug.cgi line 303"

This only occurs upon submission of new bug, updates work OK.

Server Platform: RedHat 9.0
Bugzilla Version: 2.16.4 (first noticed on 2.16.3)
MySQL Version: v3.22.5
Perl Version: v5.8.0

Modules Versions:
Checking for       AppConfig (v1.52)   ok: found v1.55
Checking for       CGI::Carp (any)     ok: found v1.26
Checking for    Data::Dumper (any)     ok: found v2.12
Checking for     Date::Parse (any)     ok: found v2.27
Checking for             DBI (v1.13)   ok: found v1.38
Checking for      DBD::mysql (v1.2209) ok: found v2.1021
Checking for      File::Spec (v0.82)   ok: found v0.86
Checking for      File::Temp (any)     ok: found v0.14
Checking for        Template (v2.07)   ok: found v2.10
Checking for      Text::Wrap (v2001.0131) ok: found v2001.0929
Checking for       CGI::Carp (any)     ok: found v1.26
 
The following Perl modules are optional:
Checking for              GD (v1.19)    not found
Checking for     Chart::Base (v0.99)    not found
Checking for     XML::Parser (any)     ok: found v2.31


Also, mail does not get sent to assignee or cc's, and I believe it's related to
this problem.

NOTE: This installation seemed to work for a couple of days and a few bug
submissions, then developed this problem.  The only intervening change I made
was to add an additional alias for the Bugzilla directory in the httpd.conf file.

Reproducible: Always

Steps to Reproduce:
1. Add new bug
2. Submit new bug
3.

Actual Results:  
Get "Software Error: Insecure dependency in exec while running with -T switch at
/var/www/html/<bugzilla directory>/post_bug.cgi line 303."

Expected Results:  
"Bug Processed"
Are you sure you're running 2.16.4?  This was fixed in 2.16.4

*** This bug has been marked as a duplicate of 177828 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Oops ... my bad; haven't used CVS in a while and didn't get the update installed
properly.  This is indeed fixed and thanks a bunch for the quick reply.
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.