Closed Bug 225806 Opened 17 years ago Closed 17 years ago

oncontextmenu - _user_ should decide if he wants the webpage to modify this event

Categories

(Core :: DOM: Events, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 86193

People

(Reporter: marcoos, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; PL; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; PL; rv:1.5) Gecko/20031007 Firebird/0.7

Some stupid websites like to block the context menu of the browser by overriding
the default document.oncontextmenu() method to return false:

document.oncontextmenu = new Function("return false");

This makes the context menu not work at all. And is as annoying as pop-ups.

The _user_ should have the possibility to decide if he wants the page to modify
_his_ browser behaviour, and the default setting should be _no_.

However, there are some sites (but no more than 1%) that make some fair use of
the contextmenu event. It would probably be good to have a white-list and a
black-list of sites using oncontextmenu (similar to the cookie or pop-ups
white/black-lists)

Reproducible: Always

Steps to Reproduce:
1. Go to a website with document.oncontextmenu = new Function("return false") or
something similar

Actual Results:  
The menu becomes blocked. Right click is useless.

Expected Results:  
An icon at the bottom-left window of Firebird (and SeaMonkey, too) should
appear, notyfing the user that the site wants to modify the contextmenu event.

Clicking the icon should display a window, which would allow to grant or deny
permission for a site to do such a weird thing.

This can be similar to the pop-up blocker management window, e.g.:

+-----------------------------------------------------------+
| These sites were blocked from modyfing your context menu: |
| +-------------------------------------------------------+ |
| | stupidsite.com                                        | |
| | destroyyourcontextmenu.net                            | |
| |                                                       | |
| +-------------------------------------------------------+ |
| [Unblock Site]                                    [Done]  |
+-----------------------------------------------------------+

*** This bug has been marked as a duplicate of 86193 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.