Every time I click a download link - the nightly build of Mozilla crashes

RESOLVED DUPLICATE of bug 225995

Status

--
critical
RESOLVED DUPLICATE of bug 225995
15 years ago
14 years ago

People

(Reporter: zeitgeist, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 98
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031114
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031114

I installed the nightly build of Mozilla tonight. I tried downloading some files
and the browser crashed before the download manager could open. I ended up
rebooting a while later. I tried downloading something from another website and
the browser crashed with a fault in the same DLL file. I ended up rebooting
after installing something. I tried downloading more software and when I clicked
the link - the same thing happened. 

Reproducible: Always

Steps to Reproduce:
1. Click link to download DirectX from Microsoft.com
2.
3.

Actual Results:  
The browser crashed.... windows dialog poped up with More Detail button.. I took
a screenshot (after the 3rd failed attempt to download). 

Expected Results:  
Download the file? :)

Theme: Modern

I clean installed Win98SE on this system this week. All Microsoft patches are up
to date. This is a stable system (I usually run Slackware 9.1). There is hardly
anything installed on this machine, including startup programs/spyware. The last
nightly build I had was a couple of days ago - I had no similar problems with
Mozilla. I have no third party download managers.

MOZILLA: This program has performed an illegal operation and will be shut down.
If the problem persist, contact the program vendor.

MOZILLA caused an invalid page fault in module XPCOM.DLL at 0167:1000167a. 
EAX=00000000 CS=0167 EIP=1000167a EFLGS=00010246
EBX=00000000 SS=016f ESP=0066f314 EBP=0066f32d
ECX=00000000 DS=016f ESI=0066f348 FS=3b37
EDX=00000000 ES=016f EDI=00000000 GS=0000
Bytes at CS:EIP:
66 8b 11 41 41 66 85 d2 75 f5 c3 8b 44 24 04 89
...
etc.

Comment 1

15 years ago
Also using the 2003111415 win32 build on a win98se box, Mozilla consistently
crashes hard in XPCOM.DLL if I try to read an email or if I try to open a Mail
compose window, crashes before Talkback can even fetch some info.  Here is my
stack dump.

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 0167:1000167a.
Registers:
EAX=00000000 CS=0167 EIP=1000167a EFLGS=00010246
EBX=00000000 SS=016f ESP=0066e774 EBP=0066e78c
ECX=00000000 DS=016f ESI=0066e7a8 FS=317f
EDX=00000000 ES=016f EDI=00000000 GS=0000
Bytes at CS:EIP:
66 8b 11 41 41 66 85 d2 75 f5 c3 8b 44 24 04 89 
Stack dump:
1003ea3e 00000000 03730030 00000000 00000000 80000000 0066e808 01a58330 00000000
ffffffff 0066eb94 03730030 00000000 10044960 0066e7b8 00000000 

Should this be marked as a XPCOM problem?

Change summary to crash in XPCOM.DLL?

Comment 2

15 years ago
wfm 20031113 Win2k, possible regression.
Keywords: crash, stackwanted

Comment 3

15 years ago
Confirming crashes when clicking on a download link and sometimes in mail with
20031114 and 20031117 on Win98. Sorry, Talkback doesn't come up.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
please reopen if you still crash with build 2003111723 (not 2003111712) or later.

*** This bug has been marked as a duplicate of 225995 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.