Content not displayed properly - scrolling on this large page

VERIFIED DUPLICATE of bug 1177

Status

()

Core
Layout
P2
normal
VERIFIED DUPLICATE of bug 1177
19 years ago
19 years ago

People

(Reporter: Paul MacQuiddy, Assigned: michaelp)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Obtained from the mozilla.layout newsgroup. I duplicated the problem with Jan.
8 viewer.exe on win95. The page is 72k with 2500 lines.

Win95
Mozilla nightly build, downloaded night of Dec. 30

Try displaying this long source code listing (with lots of hyperlinks).

http://cvs-mirror.mozilla.org/webtools/lxr/source/htmlparser/src/CNavDTD.cpp

If you try scrolling down, either nothing is displayed, or the display is
incomprehensible.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 1

19 years ago
Micheal -- please verify on win98. On NT this bug does not occur.
Assignee: rickg → michaelp
Status: RESOLVED → NEW
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
(Reporter)

Comment 2

19 years ago
Hmmm. I still see this with Jan27 optimized build on win95. I've asked a few
other people to check this out on their machines.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 3

19 years ago
Under Win 98, many Bad Things happen with this page. If you scroll by dragging
the thumb, the top of the page (about 200 pixels) is redrawn over and over
again, repeating itself. If you scroll by clicking on the down arrow, that same
section moves up and the page becomes blank; if you then force a redraw by
switching to another app and back, it looks like you're at the top of the page.
I've seen other weird behavior as well.

Comment 4

19 years ago
Tested using 1/27 build on Win 95 and Win 98. Same strange behavior. Initially
only the top of the page loads. Once you begin to scroll, text displays on top
of text. Also tested on NT - page would not load and hung application up - tried
this three times.

Updated

19 years ago
Summary: Cannot scroll on this large page → Content not displayed properly - scrolling on this large page

Comment 5

19 years ago
Jan 27 build - What I saw on my win98 machine here at home is a blank page and
when I scrolled, text started to appear but overwriting itself slowly becoming a
nice huge graphic blob.  Possible memory overwrite in layout?

Reopening, adjusting bug title to match actual problem, since you can scroll but
content is missing or garbled, old title was "Cannot scroll on this large page".

Comment 6

19 years ago
1/26/99 build
Win98

Looks like hell on Win98 using non-debug build.

Comment 7

19 years ago
Setting all current Open/Normal to M4.
(Reporter)

Comment 8

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 9

19 years ago
*** This bug has been marked as a duplicate of 1177 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.