bookmark menu/toolbar does nothing in new window

RESOLVED DUPLICATE of bug 223611

Status

()

--
major
RESOLVED DUPLICATE of bug 223611
15 years ago
12 years ago

People

(Reporter: qtmstr, Assigned: p_ch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031117 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031117 Firebird/0.7

Whenever I go to file->new window in firebird, or open a new window in a
different way, the bookmarks menu and the bookmarks toolbar do nothing when I
click on a link. Right-clicking, I get a small menu-colored box with nothing in it.

Bookmarks SIDEBAR does work, however.

Reproducible: Always

Steps to Reproduce:
1. Have existing browser window with bookmarks
2. Create a new window with file->new window
3. Attempt to use bookmarks

Actual Results:  
Nothing happens. Context menu for bookmarks doesn't exist anymore either.

Expected Results:  
Allowed me to use the bookmarks features as normal.

In the javascript console, I get the following error when I close a new window.
I don't know if it's related:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://browser/content/browser.js :: Shutdown :: line 466"  data: no]
(Reporter)

Comment 1

15 years ago
Oops. Firebird-specific
Component: Bookmarks → Bookmarks
Product: Browser → Firebird
Version: Trunk → unspecified
No problems with my 2003-11-18 nightly build on WinXP.
Please try a current nightly with a fresh profile without any additional themes
and extensions.

Could be linux-specific though.
QA Contact: mpconnor
(Reporter)

Comment 3

15 years ago
The build was compiled myself with gcc-3.3.1, -O2 and -march=athlon. I tried
recompiling with plain -O, but that version exhibited the behavior too. I tried
a precompiled distribution of 0.7, and that worked fine.

This happens with no extensions loaded (rm -rf /opt/firebird-0.7.1; rm -rf
~/.phoenix; make install).

Where can I get the source for the nightlies? I don't see it in the nightly
directories.

Comment 4

15 years ago
This was happening a while back, but has been fixed now. Where did you get the
source from? You can get up to date source code through CVS I think.

I'm resolving this bug because this problem has been fixed. Duping it as bug
223611 since that's the bug that shows the fix.

*** This bug has been marked as a duplicate of 223611 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.