64bit safe code for mozilla/db (WinXP AMD64)

RESOLVED FIXED

Status

enhancement
RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Curretly code is defined as pointer type.

 typedef long           mork_ip;  // make sure sizeof(mork_ip) == sizeof(void*)

But WinXP 64bits for AMD64 is that "long" type is defined as 32 bits.  So please
consider this platform.

Reproducible: Always

Steps to Reproduce:
Not need.  This is build issue.

Actual Results:  
Not need.  This is build issue.

Expected Results:  
Not need.  This is build issue.

Comment 2

16 years ago
Comment on attachment 135939 [details] [diff] [review]
mozilla/db diff

r=bienvenu
Attachment #135939 - Flags: review+
Confirming this bug (setting status to NEW) based on David's review.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Makoto, you should now request sr, see http://mozilla.org/hacking/reviewers.html.
Old patch isn't simple.  We should replace with PRWord/PRUword, because PRWord
should become void*.  Please see #226094 about PRWord/PRUword's discussion.

Updated

15 years ago
Blocks: 237202

Updated

15 years ago
Attachment #139489 - Flags: review?(bienvenu) → review+
Assignee: bienvenu → m_kato

Comment 7

15 years ago
Comment on attachment 139489 [details] [diff] [review]
diff at 2004/01/20

would you like me to check this in as well?
Attachment #139489 - Flags: superreview?(bienvenu) → superreview+
(In reply to comment #7)
> (From update of attachment 139489 [details] [diff] [review])
> would you like me to check this in as well?

I have a permission for check in.  So I checked in.

Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.