Deleted too much when cleaning out old version on overwrite install

RESOLVED DUPLICATE of bug 69153

Status

SeaMonkey
Installer
--
blocker
RESOLVED DUPLICATE of bug 69153
15 years ago
14 years ago

People

(Reporter: Phillip, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla 1.5 for Linux (Sorry, I don't have access to the entire descriptor now)

I was trying to replace the version of Mozilla that came with RedHat 8.0. 
RedHat puts Mozilla in /usr/bin/.  I went to install the new version in /usr/bin
(as root), and was told I already had a copy of Mozilla there.  It asked if I'd
like to remove the old version prior to installing the new version.  I said yes.

The installer removed ALL of my executable files from /usr/bin, necessitating a
complete rebuild of my Linux system.

Reproducible: Didn't try

Steps to Reproduce:
1. Run the installer
2. Select /usr/bin as the destination
3. Watch as you are no longer able to do anything, because you have no system
commands available.

Actual Results:  
I couldn't do much of anything on my system, as many OS commands (cp, etc.) were
gone.

Expected Results:  
Only removed mozilla-specific executables

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 69153 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.