Grayed out areas on VA Linux index page

VERIFIED DUPLICATE of bug 16100

Status

()

P3
normal
VERIFIED DUPLICATE of bug 16100
19 years ago
19 years ago

People

(Reporter: cesarb, Assigned: pnunn)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When opening the valinux site (any of its pages), it starts displaying
correctly, then as the non-background images start to be rendered the page turns
into a gray mess with only some images appearing. Forcing a redraw (either by
reducing the window to its titlebar only and expanding it back, going to another
desktop, or simply scrolling the page one or two screenfuls down and back up)
makes most of the page appear correctly, except for a horizontal gray bar which
starts below the login/pass form on the left column and spans the whole canvas
width. No amount of scrolling and redrawing reduces this bar's size or make it
disappear (but sometimes make more horizontal bars appear above or below it;
these new glitches can be removed by redrawing as usual). This grey bar covers
part of the page (making it impossible to read some of the text), and looks like
a undrawn place (i.e. not drawn yet).
(Reporter)

Comment 1

19 years ago
Damn, I always forget something. Using Debian's M12 mozilla package,
I-know-it's-wrong build ID 1999082316 (but it's in fact M12).

Updated

19 years ago
Summary: Rendering doesn't work very well → Grayed out areas on VA Linux index page

Comment 2

19 years ago
Based on comments added to bug 22715 by 3jrgm@qlink.queensu.ca, and visual
inspection of the VA Linux page at the above URL on NT, this looks like it
could be the same issue as seen in bug 22715. In this case, rather than being
transparent, the images are simply not filling out the cells they live in.

On NT, the image showing the words "VA LiNUX in the news" is showing on top of
a black bar, whose area corresponds exactly to a table cell, and whose
location corresponds to the location of the grey bar mentioned in the report.
The rest of the details of the report are confirmed, with black on NT
instead of the grey seen on Linux - and each of the other areas that get
blacked out also corresponds to the area of a table cell.

Adding an attachment: the VA Linux index page with the <BASE> element set
and border=1 added to all <TABLE> elements, for visibility of table cell
areas.

Tested with:
1999-12-28-08-M13 nightly binary on Windows NT 4.0sp3
(this obviously also needs testing on Linux with a recent M13 build)

Updating summary from "Rendering doesn't work very well" to
"Grayed out areas on VA Linux index page"

John, what do you think? is this the same issue as in bug 22715?

Comment 3

19 years ago
Created attachment 3871 [details]
VA Linux page with table borders and BASE href set

Comment 4

19 years ago
Yep, sidr, it appears that transparent GIFs used for TD BACKGROUND are painting
as black (on NT), rather than transparent. Not sure if this is a painting bug,
or tables, or imagelib. (The images in question are
www.valinux.com/images/site/hline.gif and www.valinux.com/images/site/vline.gif)

I don't see the gray bar mentioned in the initial report, but that is
likely a platform-specific artifact (I'm on WinNT 1999122208).

Updated

19 years ago
Assignee: troy → pnunn

Comment 5

19 years ago
Not a layout bug
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

19 years ago
This is a table bug.
It threw me at first because the black cells
didn't show up when I saved the page locally.
This was due to the images having relative urls, which
meant the images were not accessible in another location.

The problem shows up when a background image in
a table cell is tiled to fill a larger space than
the image. Not just any size larger, it has to reach
a certain size to trigger the bug.

The html page is saved at
http://jazz/users/pnunn/publish/valinux.html

A simple table that displays the bug is
http://jazz/users/pnunn/publish/valinux2.html

A modified version of the table from the valinux site
is here, with the full image filenames. It also displays
the problem.
http://jazz/users/pnunn/publish/valinux3.html

-pn


*** This bug has been marked as a duplicate of 16100 ***

Comment 7

19 years ago
Marking verified dup of 16100.
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Marking verified dup of 16100.

You need to log in before you can comment on or make changes to this bug.