content-disposition header gets renamed if it contains whitespace

VERIFIED DUPLICATE of bug 221028

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 221028
15 years ago
14 years ago

People

(Reporter: Morten Primdahl, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Given the header: 
Content-Disposition: attachment; filename=DTS CSV export 21-11-2003 155452.csv
Mozilla suggests to save it as DTS.csv


Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
SAved the full file name

Comment 1

15 years ago
does it also happen with 1.6a or latest nightly ?
Indeed.  That's because you need quotes around that string if it contains
whitespace in it...

Duplicate of a wontfix or invalid bug in file handling...
Whiteboard: DUPEME

Comment 3

15 years ago
bug 206788 comment 9 seems to confirm Boris' comment 2.
(Reporter)

Comment 4

15 years ago
My mistake, sorry. RFC 1521 defines the grammer of "value" used by the content-disposition,
Mozilla's behaviour is correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Reopening.  This is a dup...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 221028 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.