mail filtered out of inbox by junk mail controls still causes new mail alert

VERIFIED DUPLICATE of bug 189289

Status

VERIFIED DUPLICATE of bug 189289
15 years ago
10 years ago

People

(Reporter: brianr, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

The new message indicator will be shown every time a message arrives, spam or
not. On accounts which get several thousand junk messages a day, this results in
the new message indicator staying on all the time, which makes it completely
useless. 

Reproducible: Always

Steps to Reproduce:
1. Use your real email address on usenet, slashdot, or any porn site
2. Enable new mail notification. 
3. Enable junk mail controls. Tell junk mail controls to sort your junk mail
into a seperate folder. 

Actual Results:  
New mail indicator stays on constantly as spam pours in. 

Expected Results:  
New mail indicator shown only when non-junk mail arrives. 

(If new message notification is a "major" feature, then this should be a "major"
severity bug, since it makes the new message indicator completely useless under
common circumstances).

Comment 1

15 years ago
Note that a patch is in place for the duplicate bug, in 1.6 builds.

*** This bug has been marked as a duplicate of 189289 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
v.
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.