All Bookmarks Erased and Bookmark Toolbar functionality permanentaly broken if bookmarks are deleted.

RESOLVED DUPLICATE of bug 221843

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 221843
14 years ago
11 years ago

People

(Reporter: u99, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7

Running Firebird 1.4a on OS 10.1.5:
Any of the following actions will delete all bookmark information (bookmarks,
folders, etc; everything but the "Bookmarks" folder) and render the Bookmark
Toolbar functionality broken (even if the bookmark component is transferred to a
different toolbar, it still does not work.  Items dragged into the toolbar are
not transferred there and you get the OSX "error beep."):
-Delete any bookmark or folder but the default "Mozilla Firebird and Mozilla"
and "Quick Searches" folders.
-Add a bookmark to the toolbar by dragging its icon.

Reproducible: Always

Steps to Reproduce:
1.Open Firebird.
2.Delete a divider, bookmark, or folder besides the default "Mozilla Firebird
and Mozilla" and "Quick Searches." OR Drag a URL to the bookmarks toolbar.
3.Quit/Relaunch

Actual Results:  
Bookmarks are cleared and bookmark toolbar functionality is broken.

Expected Results:  
Deleted the selected bookmarks or added URLs/icons to the toolbar.

Fix/Reset:
You can reset Firebird to its original state (with original bookmarks) by
deleting the contents of your "Phoenix" folder (shouldn't that be renamed
Firebird by now?).

This bug is critical, as it BREAKS ALL BOOKMARK FUNCTIONALITY.

Not reproduceable in Camino.
(Reporter)

Comment 1

14 years ago
Clarification:
Post-errors New boomarks can be added to the bookmarks menu.
(Reporter)

Comment 2

14 years ago
This issue does not crop up under root.
(Reporter)

Comment 3

14 years ago
What items deal with bookmarks and vary from user to user?
(Reporter)

Comment 4

14 years ago
Now root is affected, too.
(Reporter)

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 221843 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.