DHTML on <TR> won't render a cell across whole table despite COLSPAN directive

RESOLVED DUPLICATE of bug 112113

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 112113
15 years ago
15 years ago

People

(Reporter: John Marino, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 7.23  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

This page contains a row that is not visible using [style="display: none"] in 
the <TR> tag.  When clicking on an icon, a javascript function changes the icon 
source and changes the style display value to "block".  The row becomes visible 
as expected, but the contents of the row do not render as they would if the row 
was not supressed when the page was first rendered.

Reproducible: Always

Steps to Reproduce:
1. I created a snapshot of the bug page - just go the URL and click on the plus 
[expand] icon that preceeds procedure 1.60
2.
3.

Actual Results:  
The row beneath 1.60 is made visible.  It contains a single cell that spans 4 
columns (which works if you remove the [style="display: none"] attribute).  
However, Firebird renders this cell in only the first column.  It ignores the 
COLSPAN tag.  Either that, or doesn't take up 100% of the inner space.

Expected Results:  
The newly exposed table row should span the entire space just as it does when 
[style="display: none"] attribute is missing from the <TR> tag.
This works as expected in Microsoft Explorer 6

Part2: The top row of the table contained in the DHTML-collapsible row is also 
not being rendered correctly.  It has a separate class that bolds the text, 
changes the font, and puts a thin blue border on the bottom side of the cell.  
The thin blue border is missing... it wasn't rendered even though the font was 
changed along with the font weight

Comment 1

15 years ago
Not Firebird-specific. Off to Browser - Layout (Tables)
Component: General → Layout: Tables
Product: Firebird → Browser
Version: unspecified → Trunk
(Reporter)

Comment 2

15 years ago
I just checked in Mozilla 1.4 - it does the same thing, and also when you click 
the icon again to collapse the row, the cell is erased, but the row height stays 
the same.  Clicking it again doubles the row height.  Repeated clicking expands 
the row height to several pages.

I have seen this on Mozilla pages in the past - I'm glad I could provide a 
reproducible example of this behavior.

Comment 3

15 years ago
You probably should be setting the TR to display: table-row, not block.

This is probably a dup of another bug, or invalid.  I know I've seen bugs on
this before.

Comment 4

15 years ago
->Default owner
Assignee: blake → table

Comment 5

15 years ago
Comment 3 is correct.

*** This bug has been marked as a duplicate of 112113 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

15 years ago
I verified that using "table-row" instead of "block" resolved my problem.

As a bonus, this also worked for Opera 7.23, which was choking on the block even 
worse than Mozilla was.  Thanks.
(Reporter)

Comment 7

15 years ago
One final follow-up --

MSIE doesn't even accept the changing of the style attribute to "table-row", it 
produces a javascript error.  It is obviously a problem with MSIE, but this is 
probably the reason everyone keeps using the "block" setting incorrectly.

I had to make the function use table-row/block depending on the browser.  Not 
very clean.  It would be nice if Mozilla and Opera supported this even though it 
is against standard since such a high percentage of people still browse with 
MSIE.
You need to log in before you can comment on or make changes to this bug.