if browser.cache.memory.enable is set to false, this page fails to render at all.

RESOLVED DUPLICATE of bug 184304

Status

()

defect
RESOLVED DUPLICATE of bug 184304
16 years ago
11 years ago

People

(Reporter: ddyer, Assigned: darin.moz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031030
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031030

browser.cache.memory.enable = false shouldn't prevent 
any page from rendering at all, right?  This bug is present
in many versions of mozilla and is shared with netscape.

This obscure config variable is being manipulated as a workaround
until bug 204374 is fixed

Reproducible: Always

Steps to Reproduce:
1. use about:config to see and set the variable to false
2. go to the page
3.

Actual Results:  
nothing happens.

Expected Results:  
the page should display

Comment 1

16 years ago
I can reproduce this with a 20031122 Firebird on XP. Confirming, setting
component to cache for now.
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: Cache
Ever confirmed: true
lorenzo, please also reassign when changing component
Assignee: general → darin
QA Contact: general → cacheqa
(Reporter)

Comment 3

16 years ago
another web page that fails to display is 
http://www.fotolog.net/

Comment 4

16 years ago
Both servers has a "Pragma: no-cache" in the response headers, but websites with
the "Pragma"-metatag still works.
(http://www.shutterfly.com/ is redirected to http://www.shutterfly.com/index.jsp
which responses the "Pragma: no-cache" header.)

Did somebody found a site with "Pragma: no-cache" but correct shown content?

Comment 5

16 years ago
This behavior is also described in bug 184304.

Comment 6

16 years ago
This may be a dup, but comment #4 seems to point to a different cause.

Comment 7

16 years ago
In addition to comment 4, the both examples also sent a "Cache-Control:
no-cache". Also all examples from bug 184304 has a "Pragma: no-cache" and shows
no content when I disabled the memory cache.
Marking this bug as duplicate cause bug 184304 comment 1

*** This bug has been marked as a duplicate of 183404 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

16 years ago
Sorry, wrong duped to wrong bug.

*** This bug has been marked as a duplicate of 184304 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.