No tab gets focus if tabbed page with body onunload=nonexistantfunction() is closed

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Jie Gao, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031119 Firebird/0.7+ (aebrahim)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031129 Firebird/0.7+ (aebrahim)

If I am using multiple tabs, one of them is displaying
http://software.yalaso.net/ , and I close this tab, none of the rest tabs will
have focus. And after it if I continue clicking on the tab close button, I will
close a page but the corresponding tab will not disappear. So I end up with more
tabs than pages, with some tabs that can never be closed.

I experience this problem in Nov 29's official nightly win32 build, and all
builds from aebrahim and cypher77 (refer to the Firebird build forum on
MozillaZine.org) after Nov 19. At least one person confirmed this. And some one
said about similar problem they ever had.

Reproducible: Always

Steps to Reproduce:
1. Open 3 or more tabs using Ctrl-T or what ever way you like
2. Switch to one of the tabs in the middle and let it go to
http://software.yalaso.net/
3. Close this tab

Actual Results:  
None of the rest tabs will get the focus. If continue cloing tabs without
clicking any tabs to give them focus, the browser will end up with more tabs
than actual pages displaying. And the spare tabs with no pages associated cannot
be closed until closing the whole browser.

Expected Results:  
The next tab should get the focus. And no problem when closing more tabs.

Aebrahim's builds: http://pryan.org/firebird/aebrahim/

Cypher77's build: http://www.xhost.info/MozillaFirebird-20031130-O1-G7-SSE.exe
(only the latest build is provided)

Comment 1

14 years ago
That's odd... The problem appears at that site, but not others. Its body tag has
onunload=sethome(), but sethome() isn't defined anywhere. I'm guessing this
might have to do with the problem.

Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031130 Firebird/0.7+. It works in Seamonkey 2003112008.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
Yes, your analysis seems correct. I made up a page by myself, and in the <body>
tag I added onunload="nonexist()", where the javascript function nonexist() does
not exist. So the body tag looks like <body onunload="nonexist()">. I tested
this page with Firebird and I got the same result as the odd website.

So now I think probably the problem is due to the javascript error at the time
of closing the tab.

Updated

14 years ago
Summary: Multi-tab browsing: No tab get focus after closing a tab displaying some particular web pages → No tab gets focus if tabbed page with body onunload=nonexistantfunction() is closed
Is this still an issue?

Comment 4

13 years ago
Nope. Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.