Last Comment Bug 227152 - Documentation for MailNews Default Account is incomplete/wrong/not indexed
: Documentation for MailNews Default Account is incomplete/wrong/not indexed
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Help Documentation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.1b2
Assigned To: [:rickiees] Ricardo Palomares
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-30 23:58 PST by Stefan Borggraefe
Modified: 2010-10-30 16:07 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
First try to solve points addressed by Stefan (3.35 KB, patch)
2010-10-29 16:53 PDT, [:rickiees] Ricardo Palomares
no flags Details | Diff | Review
Second try taking Jens' suggestions into account (3.47 KB, patch)
2010-10-30 04:04 PDT, [:rickiees] Ricardo Palomares
jh: review-
Details | Diff | Review
Third try with changes from comment #8 [Checkin: comment 11] (3.48 KB, patch)
2010-10-30 15:26 PDT, [:rickiees] Ricardo Palomares
jh: review+
Details | Diff | Review

Description Stefan Borggraefe 2003-11-30 23:58:02 PST
The documentation for the "Set as Default" button of the MailNews Account
Settings dialog has several issues.

># Set as Default: Select an account, then click this button to make the 
>selected account appear at the top of your list of accounts in the Mail Window. 
>The change takes effect the next time you open Mail & Newsgroups.

Umm, so setting the default account is for sorting acounts? ;-)

>The default account is the one that you want to log into and (for IMAP accounts 
>only) automatically check for new messages when you first start Mail & 
>Newsgroups. (For POP accounts, you must always click the Get Msg button to get 
>new messages.)

As far as I can see whether an account is checked at startup or not solely
depends on the setting "Server settings|Check for new messages at startup".

Some thinks that should be added to the documentation of the default account IMHO:

- the default account is the account used when you click a mailto: link. The
default account is even used when you click on a mailto: link in an email
received from another account.

- the default account is the account used to create an email when you select
File|New|Message.

- the message count shown in the Windows XP login screen is the number of new
messages received with the default account.

Furthermore when you search for "default", "set as default" or "default account"
  you currently find no information about the default account.
Comment 1 Daniel Wang 2003-12-01 00:37:35 PST
thx for debugging Help!

Stefan, do you have time to become QA for Documentation:User and Mozilla:Help?
Basically all you need to do is to VERIFY fixed bugs and filter bugs.
Comment 2 Robert Kaiser (not working on stability any more) 2009-06-14 17:41:48 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 3 Ian Neal 2010-05-18 13:41:35 PDT
Still valid on SM2.x -> NEW
Comment 4 [:rickiees] Ricardo Palomares 2010-10-29 16:53:13 PDT
Created attachment 487095 [details] [diff] [review]
First try to solve points addressed by Stefan

It is probably too rough yet to be accepted, but it is a first step.
Comment 5 [:rickiees] Ricardo Palomares 2010-10-29 16:55:45 PDT
I've taken the freedom to add your e-mail to the CC list, Jens, to avoid overload IanN. Hope that's fine. :-)
Comment 6 Jens Hatlak (:InvisibleSmiley) 2010-10-30 03:07:52 PDT
Comment on attachment 487095 [details] [diff] [review]
First try to solve points addressed by Stefan

>-      <li><strong>Set as Default</strong>: Select an account, then click this
>-        button to make the selected account appear at the top of your list of
>-        accounts in the Mail Window. The change takes effect the next time you
>-        open Mail &amp; Newsgroups.
>+      <li id="set_as_default"><strong>Set as Default</strong>: Select an
>+        account, then click this button to make the selected account the
>+        default one. The default account will appear at the top of your list
>+        of accounts in the Mail Window. The change takes effect the next time
>+        you open Mail &amp; Newsgroups.

I see you didn't introduce it, but please change "Mail Window" to "Mail window" (cf. the end of your patch) at least in the lines you change. It's not a word mark or something.

>-        <p>The default account is the one that you want to log into and (for
>-          IMAP accounts only) automatically check for new messages when you
>-          start Mail &amp; Newsgroups. (For POP accounts, you must always click
>-          the Get Msg button to get new messages.)</p>
>+        <p>The default account provides the default address value for the From:
>+          header of mail messages you compose (not reply) from a folder in
>+          Local Folders, or by clicking in a mailto: link.</p>

I think "reply to" should be more correct, and there's no "in" after "clicking".

Otherwise I think we shouldn't get too technical ("From: header") here, and the composition case is probably not limited to Local Folders (think pressing Ctrl+M in the browser).

Suggestion: "The default account determines which address is filled into the From: field when you compose a new mail with no other mail or news account active (Local Folders or blogs & news feeds account; from the browser, and external application or any mailto: link)."

(In reply to comment #5)
> I've taken the freedom to add your e-mail to the CC list, Jens, to avoid
> overload IanN. Hope that's fine. :-)

Meanwhile I've changed my Bugzilla preferences so that I receive any changes made to Help bugs, so you don't need to CC me anymore, but thanks.

If you are really concerned about Ian, why not officially request review from me? ;-)
Comment 7 [:rickiees] Ricardo Palomares 2010-10-30 04:04:20 PDT
Created attachment 487155 [details] [diff] [review]
Second try taking Jens' suggestions into account

Some comments:

- The "Mail Window" occurrence you spotted is the only one in the file, but I'll try to remember if I run into more in other bugs I intend to take.

- "clicking in" is something you have told me a couple of times already. :-) I try to remember it, but from time to time I forget it, sorry.

- I've slightly modified your rephrase of the default account explanation.

- You want it, you have it. I'm requesting review from you this time. ;-)
Comment 8 Jens Hatlak (:InvisibleSmiley) 2010-10-30 10:13:43 PDT
Comment on attachment 487155 [details] [diff] [review]
Second try taking Jens' suggestions into account

>+       <rdf:Description ID="default_account"
>+         nc:name="Default account"
>+         nc:link="mailnews_getting_started.xhtml#set_as_default"/>

Nit: "default account" (checking other nc:name values in the file, capitalization is only used for proper nouns).

>+        <p>The default account determines which address is filled into the
>+          From: field when you compose a new mail with no other mail or news
>+          account active (ie.: from Local Folders or a blogs & news feeds
>+          account; from the browser; by an external application request; or by
>+          following any mailto: link).</p>

Nits: "i.e." and "&amp;".

Thinking about it again, the latter three items in parenthesis are independent from the current account selection so we should better reflect that. Also I think the use of semicolons is wrong here: Basically it's a list which requires the use of commas. Semicolons are to be used in cases where both a comma and a full stop could be used.
Suggestion: "with either no other mail or news account active (i.e. Local Folders or a blogs &amp; news feeds account is selected), through an external application request, or by following a mailto: link."

Minusing simply because I want to see the new patch (and I tend to construct long, complicated sentences which you might want to change). Other than that I think we're almost done. :-)
Comment 9 [:rickiees] Ricardo Palomares 2010-10-30 15:26:13 PDT
Created attachment 487195 [details] [diff] [review]
Third try with changes from comment #8 [Checkin: comment 11]

Let's go with it again. :-)
Comment 10 [:rickiees] Ricardo Palomares 2010-10-30 15:45:50 PDT
Thank you for the review. Adding checkin-needed keyword to complete the work. :-)
Comment 11 Jens Hatlak (:InvisibleSmiley) 2010-10-30 16:06:17 PDT
Comment on attachment 487195 [details] [diff] [review]
Third try with changes from comment #8 [Checkin: comment 11]

http://hg.mozilla.org/comm-central/rev/bfadbfaf0556

Note You need to log in before you can comment on or make changes to this bug.