mozilla does not properly handle switching to a multi-monitor setup - the menus are displayed on the wrong monitor.

RESOLVED DUPLICATE of bug 141599

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 141599
14 years ago
13 years ago

People

(Reporter: Greg Sherman, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

I have a laptop I use for all of my computing needs. When on the road, it
functions in a single-monitor mode, and when I come home, I hook it up to a CRT
for two-display capabilities. Unfortunately, if I start Mozilla while on the
road (in single-monitor mode), it behaves quite badly when I switch the computer
to multi-monitor mode. When the browser is on my second monitor, all the menus
(File menu, Edit menu, etc.) appear as orphans on the first monitor. This also
holds true for the auto-complete area of the URL bar. 

Reproducible: Always

Steps to Reproduce:
You will need a multi-monitor setup to replicate this issue.

1. Disable any secondary monitors you have enabled. 

2. Start Mozilla.

3. Enable your secondary monitor(s).

4. Move Mozilla window to your secondary monitor area. 

On my PC, this monitor is to the right on my primary monitor. I think (although
I haven't verified this yet) that if the monitor is on the left, you will now
have issues with on your primary monitor instead. 

5. Try using any of the menus or typing an address into the URL bar. 
Actual Results:  
Displays the menus (or the auto-complete window) on the first (wrong) monitor. 

Expected Results:  
Mozilla should display the menus on the same display as the window presently is
located on.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 141599 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.