Closed Bug 227551 Opened 19 years ago Closed 5 years ago

No feedback/error message when connection to POP3 server lost, or server settings not valid

Categories

(MailNews Core :: Networking: POP, defect)

x86
All
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1400359

People

(Reporter: cote, Unassigned)

References

Details

(Keywords: uiwanted)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla Thunderbird 0.3 (20031014)  Linux

When I start thurderbird, it automaticly download new message on my pop3
account.  I see the waiting widget move and the status bar print retreving
message 1 of 9.  The widget stop after a few minutes, without any error
message..  No new mail are retreived.

First I tought the problem was with the server, but I retrive correctly my
message by telnet on the pop3 port.

Reproducible: Always

Steps to Reproduce:
1.Start thunderbing and choose the profile of my pop3 account.



Actual Results:  
Nothing

Expected Results:  
Idealy, show me the new message I got.
If not, tell me that a error as occur.

Please check back the componet, I would have like to like the bug to the pop3
mail retreval code, but I am not sure where it is.

By the way, I got another profile using IMAP from the same user.  The second
profile is working fine.
Additionnal test : 

Creating a new profile reproduce the same bug.

KMail also have trouble retriving the same message, but it give a error saying
that the connection with the server has been broken.

In my previous telnet test, I had the wrong message number.  With the proper
message number, the pop3 server start its reply but never complete it.

Since the main problem is with the pop3 server, I think we could lower the
severity of the bug to normal.  The bug is only the Thurderbirg should do a
correct error reporting.
Severity: major → normal
Summary: New mail are not retreived on a pop3 and no error message → No error message when pop3 server send incomplete response
OS -> All

Thunderbird does not issue an error when the connection to the POP3 server is
unexpectedly lost in mid-transaction. It just stops getting mail as if
everything was successful.
OS: Linux → All
Summary: No error message when pop3 server send incomplete response → No error message when connection to POP3 server lost
Duplicate of this bug: 232899
QA Contact: front-end
I've been seeing this bug recently, so I made a debug build of the 20080305 trunk on WinXP to try to find and fix it, but tracking the async events and threading and my lack of familiarity with the code has made this difficult and I've run out of free time.

It seems like the socket thread continues to poll even after the connection is broken.  Then when a new POP3 attempt is made, we get the "overriding running protocol" assertion.

I've attached my debug logs which were made with:

set NSPR_LOG_MODULES=io:5,POP3:5,SOCKS:5,nsSocketTransport:5

It notably includes the following assertions:

0[2be5270]: ###!!! ASSERTION: overriding running protocol: '!aProtocol || !m_runningProtocol', file mozilla/mailnews/local/src/nsPop3IncomingServer.cpp, line 536

0[2be5270]: ###!!! ASSERTION: m_folderStream is not null and we are assigning a non null stream to it: '!m_folderStream || !aFileStream', file mozilla/mailnews/db/msgdb/src/nsMailDatabase.cpp, line 73

0[2be5270]: ###!!! ASSERTION: XPConnect is being called on a scope without a 'Components' property!
Assignee: mscott → nobody
bienvenu, would this still be useful?
( ingenuus seems to be gone)
Component: Mail Window Front End → Networking: POP
Product: Thunderbird → MailNews Core
QA Contact: front-end → networking.pop
I'm not gone, I've just reluctantly accepted TB's flakiness and given up on fixing it myself.  Still, it would be wonderful to be able to trust Thunderbird to report failures -- ideally in a useful non-blocking and non-modal way, perhaps as part of a more detailed and capable Activity Manager.
I read the original bug report here and all i see is an anti virus program.  Sorry folks, there might be a bug in the code, but if you disable anti virus email scanning things will most likely stop being flakey.
This does not involve antivirus or firewall software as I do not and have not used either.
I can confirm this. Just noticed that TB missed checking mails for half a year without noticing me on a server which dns name was changed :(

User Agent: thunderbird version > 3.1.20 !
OS: Default win7 install in virtualbox but i tend to believe that all OS is affected.

the following pop3 error situations are not reported at all by thunderbird:

UNKNOWN_HOST_ERROR
CONNECTION_REFUSED_ERROR
NET_TIMEOUT_ERROR
UNKNOWN_ERROR

the last somewhat working thunderbird version is v3.1.20. back than it was at least able to report errors at program start and 'get mail'. imap can also only detect errors at program start and 'get mail'. is there a reason that error reporting at periodic check and 'get all new mails' were never working/implemented neither with pop3 or imap?

Steps to reproduce:

UNKNOWN_HOST_ERROR -> set server name to a non-existing dns name (f.ex. from 'pop.gmail.com' to 'nodnspop.gmail.com')
CONNECTION_REFUSED_ERROR -> set server port to a non-listening port (f.ex. from '110' to '1100')
NET_TIMEOUT_ERROR -> set server name to a machive which is f.ex. powered down
UNKNOWN_ERROR -> this is the default network error in nsMsgProtocol::OnStopRequest


Actual results:

neither fetching mail at program start, or the periodic mailcheck or pressing the buttons 'Get Mail' or 'Get All New Messages' report that something is wrong, no error messages pop up, no entry in tools/activity manager suggest that something is not working.


Expected result:

an error message should pop up that the connection to the pop3 server is not working in all four mail checking scenarios (program start, periodic check, pressing 'get mail', pressing 'get all new messages').

I think I have to go back to v3.1.20 until this is solved :(
Severity: normal → major
See Also: → 255745
Summary: No error message when connection to POP3 server lost → No feedback/error message when connection to POP3 server lost, or server settings not valid
Duplicate of this bug: 700649
from bug 700649 ...

 David :Bienvenu 2011-12-08 08:25:50 PST

You should be seeing sliding alerts telling you we were unable to connect to mail.mozilla.com - but yeah, some annotation in the ui could be nice. Blake, I don't think a global state is sufficient, since it's only a single server that's down/unreachable, so the annotation might be better on the account in the folder pane - though you could argue that adding a red state and then some ability to find out which account(s) that red state applied to would be sufficient.

Comment 4 Honza Bambas (:mayhemer) 2011-12-08 08:57:41 PST

I'm happy to work on this, but not until Christmas.

My first though is to add a red icon to the status bar beside the progress and the informational field (where you can see Connecting bla bla.. when pressing F5).  After click on it, view in a dialog, new tab, whatever, the list of errors, maybe coalesced like "Connect to mail.mozilla.com times out since 5.12.2011 till now (_details_)".  Details would expand, a bit like phone call history on iPhone, showing attempt counts, dates, exact errors, whatever more data makes sense.

This list should be also accessible from the menu, like error console is.

The icon should persist for the time we are not able to connect any of the accounts and disappear after all accounts had been successfully contacted.
Keywords: uiwanted
See Also: → 227665
Will be looked at in bug 1400359. Sorry about the forward duplicate, but this bug here has no information the other one wouldn't have, well, apart from the attachments which I'll look at.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1400359
You need to log in before you can comment on or make changes to this bug.