Using mouse to scroll urlbar listbox dismisses it

RESOLVED DUPLICATE of bug 225893

Status

SeaMonkey
Autocomplete
RESOLVED DUPLICATE of bug 225893
14 years ago
13 years ago

People

(Reporter: mhlx.os2, Assigned: Joe Hewitt (gone))

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.6b) Gecko/20031130
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.6b) Gecko/20031130

When typing a url in the urlbar, such as "moz" to list previously visited
*.mozilla.* pages, then using mouse on that listbox, the listbox gets dismissed.

This error occurs on OS/2 versions of the trunk such as 2003113008.  It also
occurs on later and earlier versions.  In fact, I narrowed the first version
down to 2003100308.  2003100208 and earlier don't show this error.

I finally got an OS/2 version to compile on my machine.  The source code is from
2003-12-05.  That debug info helped me find the error.  I saw this error message
when typing "moz":

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED)
 [nsIPrefBranch.getComplexValue]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"
  location: "JS frame :: chrome://navigator/content/urlbarBindings.xml :: update
E
  ngines :: line 222"  data: no]
  ************************************************************

So I looked at urlbarBindings.xml, and looked on lxr/bonsai and found this:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=urlbarBindings.xml&branch=&root=/cvsroot&subdir=mozilla/xpfe/browser/resources/content&command=DIFF_FRAMESET&rev1=1.28&rev2=1.29

I changed my local copy of that file from 1.29 to 1.28 (i.e. line 426) and the
urlbar error is gone (but I still got that error message above).  To make sure,
I changed back to 1.29 and the urlbar error occured again.

But according to this page, that file was changed in Dec 3, not Oct 3 :
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/xpfe/browser/resources/content/urlbarBindings.xml

I tried a recent version for win98, and it worked okay.



Reproducible: Always

Steps to Reproduce:
1.  Load OS/2 warpzilla (trunk) starting with 2003100308
2.  Visit several pages on a site (e.g. www.mozilla.org) to create a history
3.  Type name of site, or part of it (e.g. moz) on the urlbar
4.  Use mouse to scroll the list

Actual Results:  
Urlbar list disappears (gets dismissed)

Expected Results:  
Urlbar should scroll through the list of pages you have visited (that matches
what you typed)

Comment 1

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031202

seeing this too on Windows98:
typing he, I get a listbox with 6 entries from http://www.heise.de, but there
are tons more, so there is a scrollbar at the right. 
I can hover over the 6 links, and the one I´m over is highlighted, but if I
click on the slider or a arrow of the scrollbar, the listbox dismisses.
Scrolling with the keyboard using CursorUp, CursorDown, is working.
OS: other → OS/2
(Reporter)

Comment 2

14 years ago
For some reason it didn't appear on Win98SE when I tried it before.  At that
time, I installed 20031204-09 over 20030830-04, and ran it without rebooting.  I
didn't get the bug.

After reading your comment, I went to that machine with Win98SE mozilla
20031204-09 again and ran into the bug!?  Just in case the bug doesn't appear
when mozilla is newly-installed-but-not-rebooted, I even reinstalled
20030830-04, rebooted, then installed 20031204-09 again, loaded it without
rebooting, but the bug is there.
(Reporter)

Comment 3

14 years ago
Argh!  Nevermind about the possible causes I gave initially (i.e. fixing line
426).  Both 1.28 and 1.29 give the bug.  I think I got fooled because I started
with a blank history, then filled it with www.mozilla.org pages, and only
www.mozilla.org pages.  I didn't notice that when the matching listbox is
dismissed (due to mouse click) the global listbox appears.  The global listbox
looks just like the matching listbox in this case (argh!!!).  Bug after visited
non-mozilla sites, they look different.

So, the bug still exists on Win98SE and OS/2, but that one file is not the
cause.  Sorry!  :(



(Reporter)

Comment 4

14 years ago
I just tried out some win98se mozilla versions and found:

2003100304 = okay
2003100404 = bad

Compared with OS/2 warpzilla:

2003100208 = okay
2003100308 = bad

To clarify the bug, when clicking with the mouse, sometimes the matching history
listbox just disappears, but sometimes it disappears and gets replaced with the
global history listbox.  Be sure to fill the history with different sites (e.g.
go to www.google.com, then www.yahoo.com, then click on different pages at
www.mozilla.org, then type "moz" in the urlbar) so you can tell the difference.

Comment 5

14 years ago
regressed between BuildID 2003100304 and BuildID 2003100308 (comment #4)

From Bonsai:
10/03/2003 13:12 ...
10/03/2003 06:39 Bug 215928 stop scrollbar mouse events from bubbling
10/02/2003 18:01 ...

Bug 215928 onDblClick event handler IS fired on select multiple form element,
WHEN clicking on scroll controls
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 6

14 years ago
changing OS to ALL, as the bug is reported on OS/2, Win98 and Win98SE,
and LXR doesn´t show OS-specific code.

the patch from bug 215928:
http://bugzilla.mozilla.org/attachment.cgi?id=131348&action=view

checkin was to mozilla/ xpfe/ global/ resources/ content/ bindings/ scrollbar.xml
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/xpfe/global/resources/content/bindings&command=DIFF_FRAMESET&file=scrollbar.xml&rev2=1.13&rev1=1.12
OS: OS/2 → All

Comment 7

14 years ago
Feel tree to resummarize the bug with the patch to make it less likely to
attract further duplicates (this is the third, at least).

*** This bug has been marked as a duplicate of 225893 ***

*** This bug has been marked as a duplicate of 225893 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.