attachments shown as "ForwardedMessage.eml" when not displayed inline

NEW
Unassigned

Status

MailNews Core
Attachments
14 years ago
8 years ago

People

(Reporter: Jo Hermans, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
Mozilla build 2003120505 on Mac OS X 10.2.8
The bug also exists in Thunderbird build 20031202 (0.4RC1)

When viewing a digest-message, we're displaying the digest as a large message
with dozens of attachments (bug 147567 and bug 188677). When "Display Message
Attachments Inline" is checked we can see the titles of the individual messages
in the attachment list. But when the option is not checked, all you see if
"ForwardedMessage.eml" (for all of them). The bug was also mentioned in bug
26519, but it's not completely fixed.

The name "ForwardedMessage" doesn't appear in the mail at all, but seems to be
the default name for an attachment that doesn't have a name at all. When the
messages are displayed inline, we're taking the subject as the title (bug 26519).

It's possible that this bug is closed as a WONTFIX, but I still think that we
should look inside the attachment to determine the name of the attachment, even
when "Display Message Attachments Inline" isn't checked, just like bug 26519 wanted.

I'll attach 2 screendumps and a cleaned version of the message in a minute.
(Reporter)

Comment 1

14 years ago
Created attachment 136982 [details]
correct display - 'display attachments online' checked
(Reporter)

Comment 2

14 years ago
Created attachment 136983 [details]
incorrect display - 'display attachments online' not checked
(Reporter)

Comment 3

14 years ago
Created attachment 136984 [details]
digest message

Comment 4

14 years ago
Interestingly, when you open one of the attachments into its own message window, 
it displays the complete list attachments in the original message (which is bug 
203570) -- and shows them with the filenames.

Seeing this under Win2K, so Platform/OS => All/All
OS: MacOS X → All
Hardware: Macintosh → All
(Reporter)

Comment 5

14 years ago
The name 'ForwardedMessage.eml' comes from the ValidateRealName-function at
<http://lxr.mozilla.org/seamonkey/source/mailnews/mime/src/mimemoz2.cpp#265>,
and is given if the subject was never parsed.

This is probably because we don't have to display the attachment at all, so we
never bothered to parse the message. I supose this is becuse of the check for
object->dontShowAsAttachment in GenerateAttachmentData ? See
<http://lxr.mozilla.org/seamonkey/source/mailnews/mime/src/mimemoz2.cpp#301>.

Comment 6

14 years ago
This is my first post and this is the closest bug to my situation so it may fit
here.

I have a similar problem using v1.6 (Windows binary download). All the forwarded
messages in any message appear as "ForwardedMessage.eml".

There is also a "Part 1.2" and "Part 1.4" in the list of attachments too
(appears in File->Attachments" menu as well).

When I open one of the attachments a new window opens and displays it, AND all
the attachments from the original message now appear in the (new) list complete
with subject info (the original message still has the *.eml items). Clicking any
of the newly named attachments does nothing (won't open). Kind of confusing but
I have a ScreenShot of it if Mozilla want's one (jpg), I can't upload it to the
web right now.

This is particularly problematic when I try opening attachments from my
video4linux-list@redhat.com mailing list (some have over 14 attachments and all
are offset by one in the attachments list; list item #2 = first real attachment).

Info:
MZ 1.6 (Win32 binary download)
Windows 2000 SP4 (all updates)
Error present is previous versions of Mz
Display attachments inline cleared/disabled.
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> There is also a "Part 1.2" and "Part 1.4" in the list of attachments too
> (appears in File->Attachments" menu as well).

That's bug 216188
Product: Browser → Seamonkey
Depends on: 269826
Blocks: 269826
No longer depends on: 269826

Updated

13 years ago
Assignee: sspitzer → mail

Comment 8

12 years ago
*** Bug 315104 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
Dupe was from TB; moving to a likely Core component.
Dupe has an interesting test case, attachment 201857 [details].
Component: MailNews: Main Mail Window → MailNews: Attachments
Product: Mozilla Application Suite → Core

Updated

10 years ago
Assignee: mail → nobody
QA Contact: esther → attachments
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.